summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-01 20:14:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-01 20:14:16 +0100
commit113536ff120085dc1a7b12260095732209a389f8 (patch)
tree52a6c3df9c740efb71c815094e03456be4558c51 /dev-python
parent5b1915ddf98b64efdd976ca4d8fce232faf7a247 (diff)
gentoo auto-resync : 01:04:2024 - 20:14:15
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin271257 -> 271256 bytes
-rw-r--r--dev-python/alembic/Manifest3
-rw-r--r--dev-python/alembic/alembic-1.13.1.ebuild5
-rw-r--r--dev-python/alembic/files/alembic-1.13.1-pytest-8.patch68
-rw-r--r--dev-python/attrs/Manifest3
-rw-r--r--dev-python/attrs/attrs-23.2.0.ebuild5
-rw-r--r--dev-python/attrs/files/attrs-23.2.0-pytest-8.patch44
-rw-r--r--dev-python/pillow/Manifest2
-rw-r--r--dev-python/pillow/pillow-10.3.0.ebuild130
-rw-r--r--dev-python/shtab/Manifest2
-rw-r--r--dev-python/shtab/shtab-1.7.1.ebuild2
11 files changed, 260 insertions, 4 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index b47d400d6433..2302d32270bd 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index c84c5316dcaa..72a56d4dc86d 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1,3 +1,4 @@
+AUX alembic-1.13.1-pytest-8.patch 2119 BLAKE2B e03335427447649b710f5fc9daf1c62ecd0fb7452e301d49e74a0f8c2ce4d4a2eb7800e1e020b67c813fafe4ada27c28ae66c1f9b40f4db37dbeb9ae4ab2be33 SHA512 77146e56c15bcd04130bb68cb8a96cc25c221db9bb884215ea5f5b45e93708ee6cad639fc1db686c960cd265f3bee274784362be9409a50ffc0fc889162d5c24
DIST alembic-1.13.1.tar.gz 1213288 BLAKE2B 12c01f60a564c3021b3d2ae61f220822a0ca644af5097b72a826f48d04225c441f580204680674410e6e2570b5c7ee24053024863162d7d43bc423a86cddcea6 SHA512 2a5826461bec22c2efc244dd8394d34d39ed6e3511a32e8e460057ab34f9e559d28dda4ea7e34ccd30628e889a3cb37cb156596e37dba748c12a0195d78aa678
-EBUILD alembic-1.13.1.ebuild 1059 BLAKE2B 5dfe4acf00d65da4b05d8a949dca30c516e45e71a79d303a2a09bdeaf2fb85265b12935a52c5488d183a35dfdb9d0608a27cdea9864574ff21152add9959c8df SHA512 5dcfe017f47f7e345b561737eec79db2c9a0131abacf5e49c6e16d1d03142e8ac4e5f29ef2648e2dd570b8d1550d04e2cf3bb17667b793a85b195fa8bfb6ea67
+EBUILD alembic-1.13.1.ebuild 1196 BLAKE2B a9ab8592ee62e83611313e60c0c63246a1cfcd020b7c52bd396100e55ef99b230bd6e50f2c36da174720f137c7c88f83b11461798ede861bb8c46c8c0ad58aa8 SHA512 9e392a31b81e1c4613111e50117dd91d281ef23c62e036cdaba4bb4948fe6d1b1968b71f76a9cacbe21641023732a07b8cb85ff55b607b8f86e0bace0691bb20
MISC metadata.xml 516 BLAKE2B 08b11ebed2913b00e0a8c0044a50e3ca7bc0e51fcad180725c90445227fed1aed58ed89b4bed58ef5c050c3eee3c19da33aabce5cd1f7835f4b560e67ccc7744 SHA512 b4afb6af57562e6065f03db71da0dbdfc9c4337e54cbaddfa257ee7bad48dbeecfaccd765901bf65279e34cf96be3975f983017858904716a36bf8c18f33db79
diff --git a/dev-python/alembic/alembic-1.13.1.ebuild b/dev-python/alembic/alembic-1.13.1.ebuild
index d30bacd5aaea..e8a5a9d46409 100644
--- a/dev-python/alembic/alembic-1.13.1.ebuild
+++ b/dev-python/alembic/alembic-1.13.1.ebuild
@@ -34,6 +34,11 @@ BDEPEND="
EPYTEST_XDIST=1
distutils_enable_tests pytest
+PATCHES=(
+ # https://github.com/sqlalchemy/alembic/commit/6bdb9043868d4bd04ebe3fe8a4991735d5f87ed3
+ "${FILESDIR}/${P}-pytest-8.patch"
+)
+
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
# setup.cfg contains -p no:warnings in addopts which triggers
diff --git a/dev-python/alembic/files/alembic-1.13.1-pytest-8.patch b/dev-python/alembic/files/alembic-1.13.1-pytest-8.patch
new file mode 100644
index 000000000000..a681645e02ec
--- /dev/null
+++ b/dev-python/alembic/files/alembic-1.13.1-pytest-8.patch
@@ -0,0 +1,68 @@
+From 6bdb9043868d4bd04ebe3fe8a4991735d5f87ed3 Mon Sep 17 00:00:00 2001
+From: Mike Bayer <mike_mp@zzzcomputing.com>
+Date: Sun, 3 Mar 2024 23:11:50 -0500
+Subject: [PATCH] use SQLAlchemy's xdist methods
+
+Fixes to support pytest 8.1 for the test suite.
+
+the use of teardown() was based on pytest's nose
+compat, which is removed. their xdist style tests use the name
+"setup_method()" and "teardown_method()" now.
+
+We have SQLAlchemy's pytestplugin in use which uses pytest fixtures
+to invoke our own xdist style setUp and tearDown methods, which we
+are already using here, so use those for this one test.
+
+Fixes: #1435
+Change-Id: I4c49e81fca6bfa957594714009531fe12691ace5
+---
+ docs/build/unreleased/1435.rst | 5 +++++
+ tests/test_command.py | 15 +++++++--------
+ tox.ini | 2 +-
+ 3 files changed, 13 insertions(+), 9 deletions(-)
+ create mode 100644 docs/build/unreleased/1435.rst
+
+diff --git a/tests/test_command.py b/tests/test_command.py
+index c665f95..04a624a 100644
+--- a/tests/test_command.py
++++ b/tests/test_command.py
+@@ -64,7 +64,7 @@ class HistoryTest(_BufMixin, TestBase):
+ def teardown_class(cls):
+ clear_staging_env()
+
+- def teardown(self):
++ def tearDown(self):
+ self.cfg.set_main_option("revision_environment", "false")
+
+ @classmethod
+@@ -206,13 +206,12 @@ finally:
+
+
+ class RevisionEnvironmentTest(_BufMixin, TestBase):
+- @classmethod
+- def setup(cls):
+- cls.env = staging_env()
+- cls.cfg = _sqlite_testing_config()
+- cls._setup_env_file()
++ def setUp(self):
++ self.env = staging_env()
++ self.cfg = _sqlite_testing_config()
++ self._setup_env_file()
+
+- def teardown(self):
++ def tearDown(self):
+ self.cfg.set_main_option("revision_environment", "false")
+ clear_staging_env()
+
+@@ -1144,7 +1143,7 @@ class CommandLineTest(TestBase):
+ cls.cfg = _sqlite_testing_config()
+ cls.a, cls.b, cls.c = three_rev_fixture(cls.cfg)
+
+- def teardown(self):
++ def tearDown(self):
+ os.environ.pop("ALEMBIC_CONFIG", None)
+
+ @classmethod
+--
+2.44.0
+
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index 5c67d1a79db5..2e96d003bbf6 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1,3 +1,4 @@
+AUX attrs-23.2.0-pytest-8.patch 1459 BLAKE2B 3388ed0e6022b1df0634031155c93abec6cf67a46a912c6a8415356337deeae1264566b65858e88b901d1cca55a7fa4a38c6ad7ad099596396d8936337fd2c62 SHA512 10bbd4a8863fcda3be30e99137283d5112189900403018f5780511d0995bf120132bd248fdc42436912be28b09a69bda9974c97b3859c281167442cc38f32705
DIST attrs-23.2.0.tar.gz 780820 BLAKE2B a06f4f17a81fc173c37661bcf518367a1cdc9a333d2783bd2cd1ac5f0a72bd20ec1afdd964e10255624bcfa027e3a152375cd21472c177428d29bd06b29984a1 SHA512 d8b178072a028b95d8424cd3ce0c8b4e6da8558fbcbcaaef91fbd03cf51e6190aa248aa0bff853e6f7c9595bbd5a8eef9d6f68ae2830cc1cc6d826ab0dda2378
-EBUILD attrs-23.2.0.ebuild 939 BLAKE2B 1b4ae5a08a7d2fd55dfc1db2bd2052b2d8f56e2183d77e4eafe7e92835d6b20e9d47d3d46aca835177703abd66b961e93822d7bc169e6a22d468a5f0be67a87d SHA512 04ee96b6339aa1aaea13900bccf21d2bab15374178cbab0b7d40db90ed0153ba64c315c1c52232f6df27bc3eb646a989e9eb3a6e5f31e7d09b167e7b2a113d02
+EBUILD attrs-23.2.0.ebuild 1038 BLAKE2B 888102b3fa59978ec11fc65544086e4092640b73dcd8328b45d3da09f7e00ee8080bf51fe1302c2dfd45b197c204af3bd12d2d0476e34d370985bf77653b01b3 SHA512 c8a3218b2262c94a4a3a78226befb373c4e33b6905b85d08afa89c80ebfc0a652e4831ae16ee915b2011c4695e013331ba2cb7769e93f94b55be11615e82ae03
MISC metadata.xml 586 BLAKE2B d54794200f471af72d635c0cda12d773ff78f1083a9a6d2b0785b203789b2432b10ee7332f5abcd8f8dda952e10e4f981d51bbbfc4a6d461524570b3c5168f18 SHA512 b1161bb1ad04faea3ca915847d739287bc8bf9695608e49344ac6c9c4c16bb6818313a79b036df0cddde1da2d84740cf2d0b7d0c23d6cf3f22315046a3732f78
diff --git a/dev-python/attrs/attrs-23.2.0.ebuild b/dev-python/attrs/attrs-23.2.0.ebuild
index a0aa7acc3ff7..5c18c763b029 100644
--- a/dev-python/attrs/attrs-23.2.0.ebuild
+++ b/dev-python/attrs/attrs-23.2.0.ebuild
@@ -33,3 +33,8 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/python-attrs/attrs/pull/1249
+ "${FILESDIR}/${P}-pytest-8.patch"
+)
diff --git a/dev-python/attrs/files/attrs-23.2.0-pytest-8.patch b/dev-python/attrs/files/attrs-23.2.0-pytest-8.patch
new file mode 100644
index 000000000000..68e4c86c1315
--- /dev/null
+++ b/dev-python/attrs/files/attrs-23.2.0-pytest-8.patch
@@ -0,0 +1,44 @@
+From b9084fab02c009a593b604562a69f36a5915c8e5 Mon Sep 17 00:00:00 2001
+From: Denis Laxalde <denis@laxalde.org>
+Date: Sat, 2 Mar 2024 07:40:36 +0100
+Subject: [PATCH] Remove pytest.deprecated_call() in TestAssoc::test_unknown
+ (#1249)
+
+assoc() no longer raises a deprecation warning since commit
+22ae8473fb88d6e585b05c709e81e1a46398a649 but the 'with
+pytest.deprecated_call():' in that test was not removed then (in
+contrast with other test cases).
+
+Maybe this got unnoticed due to a pytest bug?
+In any case, using pytest 8+ (and keeping deprecated_call()) shows that
+no warning is raised and the test fails.
+
+Removing the upper bound on pytest in dev dependencies as tests now
+pass with pytest 8.0.
+
+Fix #1233.
+
+Co-authored-by: Hynek Schlawack <hs@ox.cx>
+---
+ pyproject.toml | 3 +--
+ tests/test_funcs.py | 4 +---
+ 2 files changed, 2 insertions(+), 5 deletions(-)
+
+diff --git a/tests/test_funcs.py b/tests/test_funcs.py
+index 044aaab..398ba35 100644
+--- a/tests/test_funcs.py
++++ b/tests/test_funcs.py
+@@ -600,9 +600,7 @@ class TestAssoc:
+ AttrsAttributeNotFoundError.
+ """
+ # No generated class will have a four letter attribute.
+- with pytest.raises(
+- AttrsAttributeNotFoundError
+- ) as e, pytest.deprecated_call():
++ with pytest.raises(AttrsAttributeNotFoundError) as e:
+ assoc(C(), aaaa=2)
+
+ assert (f"aaaa is not an attrs attribute on {C!r}.",) == e.value.args
+--
+2.44.0
+
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index c933280f4d48..0179d2132406 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -3,8 +3,10 @@ AUX pillow-10.2.0-cross.patch 2390 BLAKE2B d690b3f93d59c32d0f1b209b51ea478723089
DIST pillow-10.0.1.gh.tar.gz 50539264 BLAKE2B 83c3bf4abc9c3eab210576dc28d6f8926ce0998ec344e792433afc05190bb248a926902ce7706e3569cd6cbf8deb640cafda86f102166cf6492ec00b66f9392f SHA512 27e2f0d86563c3b7f5a2e0ba2bbe98fc2cb2fa5871d0b6cbb5a0014e9d9eb03dde9969301419d806d1a22cd4881e624465a355ba9bc42b95746226e1f95712a9
DIST pillow-10.1.0.gh.tar.gz 50798274 BLAKE2B a69be8187e7206b50350af399b73b5c43b29c249a4a5a6bb23438dae9967bb84f1d487f52b188811cb3d2e550245f8d5a765668d8d5de1375a84fcd96fc531d9 SHA512 01c97b68d4167d10539a2d29fb82676fb417ee5003f0acd9f602ed13d41b200579497cc0ef0949b2c1549b684f76f2d43895a52abdb1367345d2affd544c5b5a
DIST pillow-10.2.0.gh.tar.gz 46244216 BLAKE2B 27bb076f0adade34295e6dfec5c5a1499471036e4f5358f0b3985c064a0ae962be9e91985851b369a49162ef520a84bb20eb1a5acb074fe94d861f042e4ada92 SHA512 d77ebedfb89d541db2fcba4fc354e097b9917594170bad07c67e22de123c9e0bbc9c55a938fc152bbdcca3ce23de6fa374a6d3d3bdbd44f16dbc2616c1bddf60
+DIST pillow-10.3.0.gh.tar.gz 46636534 BLAKE2B 523486a3adc8905dbe0691e7092654e7884c34703f351e228a49b1cb6e9cffdf504b842aa0c83b18afb8f0dbe1265274044003aba540d6427ec3cd46ddda1498 SHA512 11095f435ba30ac364575271de4c94d498b6fc1d67730b8212fae6f187902129018ca950aa878843f4d1b29e25aab1be245ed313fd3bc110ccf9ce3ae266d840
EBUILD pillow-10.0.1.ebuild 3501 BLAKE2B 9f690f40ca87ce944906fd315fa702735587500b2c3948431206803aad95a09895920819eb5a44f39c2b12c01de7400042743e516fbf5c86615c39d62b067d16 SHA512 ae4ddcfdf4e60fe86eb2643f839e3a0d72dcb1e7b2d78ce6a9f476945e81d673d1b2319b09d1f69bfd6d1f27b6ed693355e1fd85536f51d6b2220484f65bdeb5
EBUILD pillow-10.1.0-r1.ebuild 3606 BLAKE2B bcec30251d71e5c9cc439bad1fef9e701721af432a05187165880ee2ba9e776ac6c7208275168e6843727d33987a7482977aacd1d6e7f77b492bd74d9ee10ebd SHA512 4ced9aa36035a8c9865497378df8fead39e50c9d61b8b47fb218031a1ba9f6ea9086d9104b594e75936ef41870e435601ee51d621f61cd1531dc6d99a1ce61cd
EBUILD pillow-10.2.0-r1.ebuild 3271 BLAKE2B dcbe6350a55e28c2fdb6cfbbe33e638bde17fa291b5b507b5071084a8cc13a16be2c87ba986e7c59acd27ffb01cfc8ea4d6ae58cc845890aee6356dc29434139 SHA512 45e05f96ad73aa58e11d6f0fce2afc4b727f6538801b861aec0f586d8714ed4270532973b063f2e3af3e0971986dd75f22606dadcb267a907930bd8d9d82a623
EBUILD pillow-10.2.0.ebuild 3509 BLAKE2B 1901ee3f18c79007ccfd0489719a022fa3d68d5c4a21d625e87579d54ebecb025eeef65b781518e3a85cf464e125887f2bd2344f7de12036b23d6ad7271d05e7 SHA512 9aef737b1689c30ce05eae1b96f9f9a83c4f3d1b5eb0223ae21a61994f8f28fceaee57d5ff5c4a3f145e8a4ae2a9700c527c29a4ef6357567361c125e39da2b9
+EBUILD pillow-10.3.0.ebuild 3292 BLAKE2B bc9bd9ca0ec5eb700772ec167e6ca2dbc0f3f6ece1734cddd920bf6b1eeb85b6a7b832c37822c77e39cee486a84ca5e6eea234722fea0ece5850da9b1ae33d20 SHA512 6a6b57b4dddb9124022dccc3c9eec551f588152d09fdc48ac7b1da7e040d778b015b337e10edca9ae2ed86185dbe1a5de29fe18d0d0dd33f92ce620878c4ea89
MISC metadata.xml 480 BLAKE2B 9fe5188b0a5eb4f19b53f34efad5c7da2ba086dd5eb9ed2e4fce8b6a6fac14d9a848392980cd1d2eaff5b334d7c5e39f58d60b763f44879d852dfb0b4f5e3efc SHA512 2b15d9e07b13a6028e87a3d5f0e72b2d252cfb2fa843783acfd2a9dd38bb6f0641f94d067f3a900fede445c606da361d509de2d4541513126b57c6782f69a5bb
diff --git a/dev-python/pillow/pillow-10.3.0.ebuild b/dev-python/pillow/pillow-10.3.0.ebuild
new file mode 100644
index 000000000000..fa573b6a4116
--- /dev/null
+++ b/dev-python/pillow/pillow-10.3.0.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+# setuptools wrapper
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 toolchain-funcs virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="
+ https://python-pillow.org/
+ https://github.com/python-pillow/Pillow/
+ https://pypi.org/project/pillow/
+"
+SRC_URI="
+ https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="examples imagequant +jpeg jpeg2k lcms test tiff tk truetype webp xcb zlib"
+REQUIRED_USE="test? ( jpeg jpeg2k lcms tiff truetype )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ imagequant? ( media-gfx/libimagequant:= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2= )
+ tiff? ( media-libs/tiff:=[jpeg,zlib] )
+ truetype? ( media-libs/freetype:2= )
+ webp? ( media-libs/libwebp:= )
+ xcb? ( x11-libs/libxcb )
+ zlib? ( sys-libs/zlib:= )
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/olefile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ || (
+ media-gfx/imagemagick[png]
+ media-gfx/graphicsmagick[png]
+ )
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/python-pillow/pillow/pull/7634
+ "${FILESDIR}/${PN}-10.2.0-cross.patch"
+)
+
+usepil() {
+ usex "${1}" enable disable
+}
+
+python_configure_all() {
+ # It's important that these flags are also passed during the install phase
+ # as well. Make sure of that if you change the lines below. See bug 661308.
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ disable_platform_guessing = True
+ $(usepil truetype)_freetype = True
+ $(usepil jpeg)_jpeg = True
+ $(usepil jpeg2k)_jpeg2000 = True
+ $(usepil lcms)_lcms = True
+ $(usepil tiff)_tiff = True
+ $(usepil imagequant)_imagequant = True
+ $(usepil webp)_webp = True
+ $(usepil webp)_webpmux = True
+ $(usepil xcb)_xcb = True
+ $(usepil zlib)_zlib = True
+ EOF
+
+ # We have patched in this env var.
+ tc-export PKG_CONFIG
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO (is clipboard unreliable in Xvfb?)
+ Tests/test_imagegrab.py::TestImageGrab::test_grabclipboard
+ # requires xz-utils[extra-filters]?
+ Tests/test_file_libtiff.py::TestFileLibTiff::test_lzma
+ )
+
+ "${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # leak tests are fragile and broken under xdist
+ epytest -k "not leak" -p timeout || die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ python_doheader src/libImaging/*.h
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples ; then
+ docinto example
+ dodoc docs/example/*
+ docompress -x /usr/share/doc/${PF}/example
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/shtab/Manifest b/dev-python/shtab/Manifest
index 88625deaaff7..21620c6109a1 100644
--- a/dev-python/shtab/Manifest
+++ b/dev-python/shtab/Manifest
@@ -1,5 +1,5 @@
DIST shtab-1.7.0.tar.gz 45485 BLAKE2B d1aef26a621da7654e5816fda7ebf197cdf23aa3a485716038b6161826b2f1a624caf369bf59a7fd611cc28906debb83f016b167f06c2cfe9d7a53724054ad55 SHA512 82e5bba15007e07c180c5d9585605150f0a5f53b3859888fcdc28c0bc537762635794f7a8ddd6f81f5337d3c7375b925380fc3797198a803fc09635b65dd07f4
DIST shtab-1.7.1.tar.gz 45410 BLAKE2B 15ed00feb1bb051ad3ec21bab9a3300175b22e677db905b714e29b10308489bec6273a7f1e226b3dd70088c74b0dd5f2c7d8958a130e339d197ba290ea6710f4 SHA512 749f21e5b4eba75744a270809b761e7c795e4404727f8e6da87f6620622e42dc6e35aa923c7f8df34bec27af45ec16496fdab11b8450edb09067df9c830ae219
EBUILD shtab-1.7.0.ebuild 566 BLAKE2B 235c26c9126dbeda7c7eee6dcc4866484d9563655f6b911091eb1e3a295a03ce30542ca2980268cba21cc811d53ac82ed36326f7c12f9d2a1cb8e06b2cae9c40 SHA512 076a95788a8ffd481974c4ae68ec713bd98557d0bb26146c473ec5a5d41440b545873a69448cdeaa1c577c121a95e22bfb840daaa77d14f1b17eaba1697d8cb0
-EBUILD shtab-1.7.1.ebuild 566 BLAKE2B 235c26c9126dbeda7c7eee6dcc4866484d9563655f6b911091eb1e3a295a03ce30542ca2980268cba21cc811d53ac82ed36326f7c12f9d2a1cb8e06b2cae9c40 SHA512 076a95788a8ffd481974c4ae68ec713bd98557d0bb26146c473ec5a5d41440b545873a69448cdeaa1c577c121a95e22bfb840daaa77d14f1b17eaba1697d8cb0
+EBUILD shtab-1.7.1.ebuild 564 BLAKE2B fe08e57aaf51fc86978c6cc60d493bbdd322f19532029888d5a902ddb7d060f790df6a7705fb18dd0886b1a735300f12830048e141d414211247ef0847d7fc8d SHA512 7e6de0920ee1ab8b068efc0acb218893c06171555000bd7553b29c0278c827386179f188efc28f2cf638596bd0e83c2883e9a8d679102961152df191d12dbf2e
MISC metadata.xml 1056 BLAKE2B da744d720169daf28375de0e42698ea7e0c1b4ac9e0f172f541389a5e1e8e86e788c586b641a58b521b2e8b23d080f41e1732ed83359141b4b4f32680d5fc58c SHA512 e8e23edd387bf397349581222ea3be84591816416b38305ba303e227677da9979a3b448004c537f4b8d8c8e1074f99a0f4fda4afcf41fcd43902731b0df6aa64
diff --git a/dev-python/shtab/shtab-1.7.1.ebuild b/dev-python/shtab/shtab-1.7.1.ebuild
index 3debac670a80..b6254c544da0 100644
--- a/dev-python/shtab/shtab-1.7.1.ebuild
+++ b/dev-python/shtab/shtab-1.7.1.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"