summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-26 07:37:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-26 07:37:53 +0000
commit058e62d5e60f6fc7f010f73f4c1546e979344a0b (patch)
treed4cc27f68681c52e6387b26f0f9daf36979ab36b /dev-python
parent15bb7733ddb1f16a0e3936969282ecc42419829a (diff)
gentoo auto-resync : 26:12:2023 - 07:37:53
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin269148 -> 269151 bytes
-rw-r--r--dev-python/argh/Manifest2
-rw-r--r--dev-python/argh/argh-0.30.5.ebuild28
-rw-r--r--dev-python/jsonschema-specifications/Manifest2
-rw-r--r--dev-python/jsonschema-specifications/jsonschema-specifications-2023.12.1.ebuild28
-rw-r--r--dev-python/pebble/Manifest2
-rw-r--r--dev-python/pebble/pebble-5.0.6.ebuild24
-rw-r--r--dev-python/pyaml/Manifest2
-rw-r--r--dev-python/pyaml/pyaml-23.12.0.ebuild30
9 files changed, 118 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 12a55e07f89b..9ec6d105a17e 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/argh/Manifest b/dev-python/argh/Manifest
index 98c8057d59b8..ff89020ddb5a 100644
--- a/dev-python/argh/Manifest
+++ b/dev-python/argh/Manifest
@@ -1,3 +1,5 @@
DIST argh-0.30.4.tar.gz 62618 BLAKE2B e95ee9219d2b8079e4b9548f68811832ed9ca699c1dcfeabcf31a9a0c3fd35c107896f088a64efe430347fefd1424345753bc4e0341155a92d99a5327f4a137d SHA512 6a17fcaef3a1a400426cc53339e07583734b0b68ce9202a7b3655f5cababa495aa5269f66cde2d0b2217874ddb730bf7d1c7636dd915e4e778058399b9b9a44c
+DIST argh-0.30.5.tar.gz 63041 BLAKE2B 3b8e928d1e6f8fd2340afa87072c35a04e4222dac7d3d549fa6040f3e1352365ff9d2b940d30f20b6aa0959a8331638e076e3f42fe7b16ff96be8734278db59c SHA512 74194010f0558335557a56ea9daa24a7301733090ffcbd201524b67727a64d8dabaeb31558f7da6f2bf51ab9354b371b09a0be55125bcaee128630df59343188
EBUILD argh-0.30.4.ebuild 568 BLAKE2B 101ad987971dbdfb496aecc1c8e0be5aa19a67df9e89accd4c0ffb000cde38a0238567d69935ce0acdb51bf2280cf88be3ab66253d09d10d07e561981f868a67 SHA512 3eb461338244c4f5a2c487c932aecaf185b3f2717fea8223b6de9353adf0d629863eb9ebf463601db19c0302d69dc09854dc823652c539d01b09572085f5cfdd
+EBUILD argh-0.30.5.ebuild 576 BLAKE2B adefc58efa7542e9e97e66d22aacbf443549eb9c97c6cb19b9cb4ed25e474016f6a60620f47333f06d17ac19183d25f1be348c97a87a13d051452c07c5cb90ba SHA512 cacf7a864e4e581f06ab6834014f67aa96e08d2dba09d8de5db00daef3dd6011e16a843a5afb5ad1c183ce85308a8e660eecd135dfd26959ba64c35ace6caaf8
MISC metadata.xml 385 BLAKE2B e1fc25e92c45fbd0183634cc645085fef5223a59975a5000557c1a2ef497c6f9ce017e462a9a881e61b4578c90859f51e5471d197ea884b7dc4ce90786a0987a SHA512 97719df6c0b48c7348bf25de9016dd1de373d6b9e1fd7f52d87eb6e0935608719c726aa3f4ca4aba8fa1211d1234c2b959dd821d241cd65b6cb47b1a06481df6
diff --git a/dev-python/argh/argh-0.30.5.ebuild b/dev-python/argh/argh-0.30.5.ebuild
new file mode 100644
index 000000000000..32a100a7ba11
--- /dev/null
+++ b/dev-python/argh/argh-0.30.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="
+ https://pythonhosted.org/argh/
+ https://github.com/neithere/argh/
+ https://pypi.org/project/argh/
+"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="LGPL-3"
+
+BDEPEND="
+ test? (
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/jsonschema-specifications/Manifest b/dev-python/jsonschema-specifications/Manifest
index 60b8aa7905a5..c3de44f6fabd 100644
--- a/dev-python/jsonschema-specifications/Manifest
+++ b/dev-python/jsonschema-specifications/Manifest
@@ -1,3 +1,5 @@
DIST jsonschema_specifications-2023.11.2.tar.gz 13033 BLAKE2B a9e64f1956a80f040eb300b772e10c7f75ed36502b69899bcadaef79086bc209d63b139bfe94cc3f30ee250bd50b9e0021e3c7616cecd08b322160cadba69046 SHA512 de990c8e6976a2a5915f9b5882f4b9da1cbe8c63a9de70aff74efeb2c659f041815186c6cb38ca9df14fefc211cae2b3c7c8af838fc4b9b853b07f7a5362f181
+DIST jsonschema_specifications-2023.12.1.tar.gz 13983 BLAKE2B db3cad7a900b114eff4827b6653da9e88b80cedae8f724fe030f373d98c7771f427a9960fa47cbe4d4b677805385a059aca08665271659b3e5ab43719c9d74d1 SHA512 7027641c65a6f7c618fd8c3b91af10bc45604966b6cf50780ca72c31f2135ec9d8b14de35049b4897586ad651b65392bb650d162f3bb546c9d250a8cd257ad30
EBUILD jsonschema-specifications-2023.11.2.ebuild 666 BLAKE2B 9069990ff2eccb89e423aa1e5be982593f9d0de1b2d5fa34e9ee091fde134eca05740b58cf8abd2b411a986a42d4b5872d176062adbe7b1a2280092919bfd6f7 SHA512 ebc07b1f1aac13c4e674345e7f2a8eacb3e53f93ba64507fbe9142ad2f3fcc94e0e7e4a3aa34acda546412d68b46bc71115512f62f4a48bb410cea396c7b66a0
+EBUILD jsonschema-specifications-2023.12.1.ebuild 673 BLAKE2B a133fc7ecc442dbe013eb0958cc96df508a833d9fb7ac2817d0df511f7e08163cd8bdffe66d3d7b7a0d911b563abc48fd8101c1f0fa04d620f8785f72ff79f7d SHA512 182458e4b21f72ea62a19677ac243ee578ff95aa07277b502f4ab4498c6e30818666be2d59b346f438edcdb07049825d01ee45ed24bee7fc0a79e9e9b625d041
MISC metadata.xml 414 BLAKE2B bc0046f51a008fe67f4937f8e9eb2663c868a41fed9371301575f74fb10c38f10b21a380d865981b317189f8c25e3ef6fe18423a169cda92b1d2b1a14dab8948 SHA512 e50f0eed8995fce7e207cb5c15106f3980ebb9c3d9d0042d33c4843be231f90aa652e59e1f83335f336d9b906a38252a229c1562f25142604048497608d29794
diff --git a/dev-python/jsonschema-specifications/jsonschema-specifications-2023.12.1.ebuild b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.12.1.ebuild
new file mode 100644
index 000000000000..9c3a40e4cef7
--- /dev/null
+++ b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.12.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The JSON Schema meta-schemas and vocabularies, exposed as a Registry"
+HOMEPAGE="
+ https://github.com/python-jsonschema/jsonschema-specifications/
+ https://pypi.org/project/jsonschema-specifications/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/referencing-0.31.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/pebble/Manifest b/dev-python/pebble/Manifest
index 67c7c50b11ab..d5cd0e7a9a55 100644
--- a/dev-python/pebble/Manifest
+++ b/dev-python/pebble/Manifest
@@ -1,3 +1,5 @@
DIST Pebble-5.0.5.tar.gz 30634 BLAKE2B 2ce70da8d2a5a8ed5368e54e63631167c09bf0f408d5e86c618fbe2237a01f0fed9e673c14fe7f8a63fb416d72bfad58c7eedd5292daf7753d067a7a219a3c22 SHA512 8d524e57e32f28fb4c59f09a7d1733d997298f526d6ba08477b060dd78c585b4f9da76b525a4052eefd1576dba464218d4b15ffe15f9e2cb1921423df3a33e1c
+DIST Pebble-5.0.6.tar.gz 30635 BLAKE2B f7525808f69fc722fa2f115c4b6d97d34077275ceaa24a5d07eb97e7d22eeecbd0f9710bdc7cbf0cb0f13e28281dbb7ea808eda89216cae44c7020533385af5f SHA512 95afadcb1cad00e6a1e0c4f40c7f77e598f5c74af04dc57999dcc1cdea237dc8f7385b2bd60b19c4f7b47e5efad0d7b7310012f45ce8975c938a554a287eb69e
EBUILD pebble-5.0.5.ebuild 569 BLAKE2B daa9148672cd8da4fee50c083d0d9408e93d62989e1ebc6a6a22f5949fa8ddb5e4f8e637f7aca3257cf8d9f0cf3ef051d541dc72ab85b9486c8413a2831e412a SHA512 3a9db95b036c5f33f0a15ea203764bf1e6885f0f0b751edb026a20be880e1b0145babf863609323710016153a31a9ab40ffebd67d783a0254d02776c6e71e194
+EBUILD pebble-5.0.6.ebuild 577 BLAKE2B 14b14ab6757d24bc6eaf216dc31c427ed170998c1de816bdf264c206f0620b6c5b85cc5045fb8981c1b9e54a78ebbddbfb0317853efa0d32e250141160f36576 SHA512 5b3ab245366920705c52a2387ee0ee1a11e0632ab7fccf8c21d2f13bdbde8f942d1fffe63043469c7b42b6424e63ddc2b8c0fdb5859efb09b90b2a470f76980c
MISC metadata.xml 367 BLAKE2B 587e93606cf39400151b413a1d1ee5446e6c6dfbde19bf2b9cd8e9a7226c1d4df53c8849625fba7c61a84ebc8939803cda5c1250c3068cb8cd61ef9db901ab6f SHA512 8f50888f29afc88c791f54078d4120eb26a0217ad76fd72f311bea4bfb769cd37adcf657bff4949fc9360b701b44d0736cd294101ce9838db538b6a34e103dd3
diff --git a/dev-python/pebble/pebble-5.0.6.ebuild b/dev-python/pebble/pebble-5.0.6.ebuild
new file mode 100644
index 000000000000..570400970374
--- /dev/null
+++ b/dev-python/pebble/pebble-5.0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Threading and multiprocessing eye-candy"
+HOMEPAGE="
+ https://pebble.readthedocs.io/
+ https://github.com/noxdafox/pebble/
+ https://pypi.org/project/Pebble/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
diff --git a/dev-python/pyaml/Manifest b/dev-python/pyaml/Manifest
index 9583064e8a96..60f04583c13a 100644
--- a/dev-python/pyaml/Manifest
+++ b/dev-python/pyaml/Manifest
@@ -1,3 +1,5 @@
+DIST pyaml-23.12.0.tar.gz 26308 BLAKE2B 89dad4c3b2a39179389c1b2e5ea6e3d93292c86f7fe5c1b55cc136f9b5a68cf7a86c6fb75a2fe44408738e53615c0062bb72511e605a8713d4381a7dff02f8fa SHA512 f1f03baf2b0a469ffbe7d6eea806cf7623a28c96221bc710873d548d8f416160bf566f44a3a42ca3572085834889e1dd394fc9bdeefe14fe23177b61573df12c
DIST pyaml-23.9.7.tar.gz 26080 BLAKE2B cb3d423c7d300147909ec7d070400206bbb1a05d226a6c6967665d950e33efe8992a8e47b6c8e7803533a88edac8192d9aa0b87d17397e2bfc45ba9bc1a97424 SHA512 f21f8c329e5233f6774701fc1e5673e62ab162fb5f8efba25120d4e157940709f47a2c90838b3af42e71b7dcfc69852393b204d0d85b6d5fba28a23f8a118be0
+EBUILD pyaml-23.12.0.ebuild 604 BLAKE2B 4d7b86356b5480c24f2562f5aae63ea99c8fdee250952349546cf8a7b7be27ffd30261df3c19051756d00b3d45ee3f1455342950021c091088ae7821742f8638 SHA512 83584617f5ce360ced493906fcd311f11ecfdfed3b772c0aff679b14f4473ae3fdbe7be30a385aa1c810806ac99901220f22d48820460f57f7cc611091d826e9
EBUILD pyaml-23.9.7.ebuild 600 BLAKE2B f24b53dafad561eb375ef90c7e167df9d6f8311ea243e839f7bfc6b0112cfafef196ffbb64746e1b7f6ad07e3e3f50aaa5f5ab56ff15e30c571892768ba70f5c SHA512 3eea1f797dddc96eb254ebb6c9c22856073e439af34035b8a67f2b4499d8b7872dac60a28ad89586ee79dfbe1600710dae7856fcd265a7d32735a890f732ed02
MISC metadata.xml 470 BLAKE2B 725657a34cdcbddf146ea3163af81fd22f78b895281e7dc2192b8c1f49fa9ec868e41a38bc371ce61160535ad0c5c1d8741109858cb8e3eafb40a77d623c3ecf SHA512 c64f440d674396b0a750780cbc5ab1a5003be1d3357b39a792cb9490870c768ab740266575cf6780f173252a893f6fa93fe9d4f414647274e520c4bd4b579c67
diff --git a/dev-python/pyaml/pyaml-23.12.0.ebuild b/dev-python/pyaml/pyaml-23.12.0.ebuild
new file mode 100644
index 000000000000..a49398baeb97
--- /dev/null
+++ b/dev-python/pyaml/pyaml-23.12.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="
+ https://github.com/mk-fg/pretty-yaml/
+ https://pypi.org/project/pyaml/
+"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest