summaryrefslogtreecommitdiff
path: root/dev-python/zstd/zstd-1.5.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-06 05:27:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-06 05:27:00 +0100
commit99d38fd80dbcd05d7ac05f9fbc86c396bacd5f7c (patch)
treeb51b6e0799ad6fb5b878f5bf637e7ef925f3ec10 /dev-python/zstd/zstd-1.5.5.1.ebuild
parent2de9aaae9b6018544ada7f67e2229605e1ec4d04 (diff)
gentoo auto-resync : 06:04:2023 - 05:27:00
Diffstat (limited to 'dev-python/zstd/zstd-1.5.5.1.ebuild')
-rw-r--r--dev-python/zstd/zstd-1.5.5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/zstd/zstd-1.5.5.1.ebuild b/dev-python/zstd/zstd-1.5.5.1.ebuild
new file mode 100644
index 000000000000..0c805254d3dc
--- /dev/null
+++ b/dev-python/zstd/zstd-1.5.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple python bindings to Yann Collet ZSTD compression library"
+HOMEPAGE="
+ https://github.com/sergey-dryabzhinsky/python-zstd/
+ https://pypi.org/project/zstd/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ app-arch/zstd:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests unittest
+
+src_configure() {
+ export ZSTD_EXTERNAL=1
+}