summaryrefslogtreecommitdiff
path: root/dev-python/zstd/zstd-1.5.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-24 06:46:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-24 06:46:57 +0000
commite8932755452c72a02ecae0b3f37395d1f607bbef (patch)
tree176877e3d181c45c4af1f0fc785749f36112a840 /dev-python/zstd/zstd-1.5.4.1.ebuild
parentdd52d0e37fe2f9a207f98abaf21108a6af8d5d3b (diff)
gentoo auto-resync : 24:03:2023 - 06:46:57
Diffstat (limited to 'dev-python/zstd/zstd-1.5.4.1.ebuild')
-rw-r--r--dev-python/zstd/zstd-1.5.4.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/zstd/zstd-1.5.4.1.ebuild b/dev-python/zstd/zstd-1.5.4.1.ebuild
new file mode 100644
index 000000000000..0c805254d3dc
--- /dev/null
+++ b/dev-python/zstd/zstd-1.5.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple python bindings to Yann Collet ZSTD compression library"
+HOMEPAGE="
+ https://github.com/sergey-dryabzhinsky/python-zstd/
+ https://pypi.org/project/zstd/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ app-arch/zstd:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests unittest
+
+src_configure() {
+ export ZSTD_EXTERNAL=1
+}