summaryrefslogtreecommitdiff
path: root/dev-python/zstd/zstd-1.4.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/zstd/zstd-1.4.9.1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/zstd/zstd-1.4.9.1.ebuild')
-rw-r--r--dev-python/zstd/zstd-1.4.9.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/zstd/zstd-1.4.9.1.ebuild b/dev-python/zstd/zstd-1.4.9.1.ebuild
new file mode 100644
index 000000000000..c7b83b1cea02
--- /dev/null
+++ b/dev-python/zstd/zstd-1.4.9.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Simple python bindings to Yann Collet ZSTD compression library"
+HOMEPAGE="https://github.com/sergey-dryabzhinsky/python-zstd"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ app-arch/zstd:=
+ !dev-python/zstandard[${PYTHON_USEDEP}]
+"
+DEPEND=${RDEPEND}