summaryrefslogtreecommitdiff
path: root/dev-python/zope-schema/zope-schema-7.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-03 08:25:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-03 08:25:41 +0000
commit2f28d79786e67cf29825843d6d04d4591a27f9cf (patch)
tree8a64339e27c973dd87bc7bf3434f082998eabe76 /dev-python/zope-schema/zope-schema-7.0.1.ebuild
parent384d032fe7e048bb10cc9bc9881835c92d7e104c (diff)
gentoo auto-resync : 03:01:2023 - 08:25:40
Diffstat (limited to 'dev-python/zope-schema/zope-schema-7.0.1.ebuild')
-rw-r--r--dev-python/zope-schema/zope-schema-7.0.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/zope-schema/zope-schema-7.0.1.ebuild b/dev-python/zope-schema/zope-schema-7.0.1.ebuild
new file mode 100644
index 000000000000..fe0606a32410
--- /dev/null
+++ b/dev-python/zope-schema/zope-schema-7.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Zope schema Architecture"
+HOMEPAGE="
+ https://pypi.org/project/zope.schema/
+ https://github.com/zopefoundation/zope.schema/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-5.0.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-zope
+"
+BDEPEND="
+ test? (
+ dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ distutils_write_namespace zope
+ eunittest
+}