summaryrefslogtreecommitdiff
path: root/dev-python/zeep/zeep-3.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/zeep/zeep-3.4.0.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/zeep/zeep-3.4.0.ebuild')
-rw-r--r--dev-python/zeep/zeep-3.4.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/zeep/zeep-3.4.0.ebuild b/dev-python/zeep/zeep-3.4.0.ebuild
index 8a508a3b5ca2..24b289bc4397 100644
--- a/dev-python/zeep/zeep-3.4.0.ebuild
+++ b/dev-python/zeep/zeep-3.4.0.ebuild
@@ -1,9 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
-PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
DESCRIPTION="A modern/fast Python SOAP client based on lxml / requests"
@@ -15,8 +18,7 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="async -tornado"
-DEPEND="dev-python/setuptools"
-RDEPEND="${DEPEND}
+RDEPEND="
>=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
>=dev-python/attrs-17.2.0[${PYTHON_USEDEP}]
>=dev-python/cached-property-1.3.0[${PYTHON_USEDEP}]