summaryrefslogtreecommitdiff
path: root/dev-python/zconfig/zconfig-3.6.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/zconfig/zconfig-3.6.0-r1.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/zconfig/zconfig-3.6.0-r1.ebuild')
-rw-r--r--dev-python/zconfig/zconfig-3.6.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/zconfig/zconfig-3.6.0-r1.ebuild b/dev-python/zconfig/zconfig-3.6.0-r1.ebuild
new file mode 100644
index 000000000000..2a5f366d1984
--- /dev/null
+++ b/dev-python/zconfig/zconfig-3.6.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P="ZConfig-${PV}"
+DESCRIPTION="Configuration library supporting a hierarchical schema-driven model"
+HOMEPAGE="https://pypi.org/project/ZConfig/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/ZConfig/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/manuel[${PYTHON_USEDEP}]
+ dev-python/zope-exceptions[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGES.rst README.rst )
+
+distutils_enable_tests unittest
+distutils_enable_sphinx doc dev-python/sphinxcontrib-programoutput