summaryrefslogtreecommitdiff
path: root/dev-python/zc-buildout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
commita8b0d35ab742f31538d515dea39716e566d533c0 (patch)
tree40c6c87a13f0e5ef1111ed1bdd9191f3bd1c1e59 /dev-python/zc-buildout
parent8fcdcec5fbdd0e3a77391e4f354218014f59f358 (diff)
gentoo resync : 06.01.2018
Diffstat (limited to 'dev-python/zc-buildout')
-rw-r--r--dev-python/zc-buildout/Manifest1
-rw-r--r--dev-python/zc-buildout/zc-buildout-2.5.3.ebuild43
2 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/zc-buildout/Manifest b/dev-python/zc-buildout/Manifest
index 1790a56155ea..5513b888d123 100644
--- a/dev-python/zc-buildout/Manifest
+++ b/dev-python/zc-buildout/Manifest
@@ -1,4 +1,3 @@
DIST zc.buildout-2.5.3.tar.gz 305163 BLAKE2B 83ef87a8b61e109498117704e4055ac533bec9be9a5d2ceb0a573808f776ca6fe607ef542ef7e7486759612da9041162a44bba19692e8ffc65c4f3cb23f99760 SHA512 a4d4becac815531cd180795372ce5896d1fdab8606fff492502ef1f59d6d1ddd8427bb00ea96d36ec284a18b17b9273d8b94a405ebe410bae7e9a6e47a8dfad7
EBUILD zc-buildout-2.5.3-r1.ebuild 1245 BLAKE2B 7d043bb8da1016f2191935fe55052704b2e644f6ec3db62253b681a550df276f1e5bea37d9c9ee619e04053fe6126b4877e7f9ac1425cc63aba2b15246c178e6 SHA512 9ab9bf094bd1f2dde51f739610c37c3cefb8a803ec15fd5b1820795b1a92767aff4592dc0756eb65c6eb8ddbaa25d7740cb29b7678703be3ca1061c50c76e5dc
-EBUILD zc-buildout-2.5.3.ebuild 1025 BLAKE2B 2b97cba428f01156ca7b07f1ff6908e751fe4c9270d99f371beceda4541255b0c0dbd8a7f886ab33514957e4888d8811a9103f6633c166fe10ab06a56092079d SHA512 be3eb00f3b60a020c519c4ae97767ccb66e5cdde48caafe7642d29404a3db0dcdf813d59798594e3eb270e0489249473a9202295754005961b3d59d58f254c74
MISC metadata.xml 1414 BLAKE2B 0a15f64e7b7abac30ebf4264fb998845069e3288f9dd7886cf916c2dd40f85204e00bf3a2f6712b05b00b1139e195c9e08906527df8992fea32aac8ef43842c1 SHA512 a5940bca5da541fbd21a7b1d7c2dd3db0d4415d336974ec1c638ad003e117480a000e780435cf254ee66d61a9f7552a13eaad2209223c5f190c4a9c96603a4e7
diff --git a/dev-python/zc-buildout/zc-buildout-2.5.3.ebuild b/dev-python/zc-buildout/zc-buildout-2.5.3.ebuild
deleted file mode 100644
index a5324fbf46e1..000000000000
--- a/dev-python/zc-buildout/zc-buildout-2.5.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} pypy pypy3 )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="System for managing development buildouts"
-HOMEPAGE="https://pypi.python.org/pypi/zc.buildout"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/setuptools-3.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}"/${MY_P}
-
-DOCS=( README.rst doc/tutorial.txt )
-
-# Prevent incorrect installation of data file
-python_prepare_all() {
- sed -e '/^ include_package_data/d' -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- if python_is_python3; then
- ewarn "Tests are broken for ${EPYTHON}, skipping"
- continue
- fi
-
- distutils_install_for_testing
- "${PYTHON}" src/zc/buildout/tests.py || die "Tests fail with ${EPYTHON}"
-}