summaryrefslogtreecommitdiff
path: root/dev-python/yolk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/yolk
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/yolk')
-rw-r--r--dev-python/yolk/Manifest2
-rw-r--r--dev-python/yolk/yolk-0.4.3-r1.ebuild14
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/yolk/Manifest b/dev-python/yolk/Manifest
index 76e8a89cf494..425b8c5fc680 100644
--- a/dev-python/yolk/Manifest
+++ b/dev-python/yolk/Manifest
@@ -1,3 +1,3 @@
DIST yolk-0.4.3.tar.gz 86100 BLAKE2B 811619b352a140c9892cac590c7e8a8c97d8f1aeb53a57e2721f80b3d1a2fe6ab7f3197ba8001313f2975e8c4e7937f87efaecd2f0f107fa251c2401bd6ce447 SHA512 ad707f4bff0cbcd3e77d9dec0734bb4d743dcada706ab1e296edafc51e1d511ab4565de64c9828275cbe0c82f35bd3f50316b74f140670f0af8276a49733f9ad
-EBUILD yolk-0.4.3-r1.ebuild 604 BLAKE2B dccf89bfe5662367db266a9f9eaffd701599f2c17f11c0fe0d51ac1a863c1c1395e6266fc5aab6ea4b3a4190aea0ae0dda82ba177c845a53107fe227cbe4332c SHA512 f3409b17257784c1321097cd4ac49b0d28af2cc5b67c8510bdf131c1bfac0ebdd7aa5db4095acdeed2fe4be32d8b554623ac963723c904765c9c22b3a356612e
+EBUILD yolk-0.4.3-r1.ebuild 672 BLAKE2B 4ec707f62a4fcaee58d1c9acbffa8f3050bf2063aa6f875bdede3e83427cc636a86b0c97c2c51dfb38a10d3e32ed3b0a6bfcd2563f5570a8e9d302f1ae014427 SHA512 b4b408a1349eee18a78c4a823b16afeeb91a918cd44734495766e015898dbc13407bcf33f55ab33052921561760afd888bf2d309f58efb4a2035f5d1baec80f6
MISC metadata.xml 565 BLAKE2B 2a57d0fb8d9318652672861f381fece1a78d57493a4cd4427b040b521c6fe5666d59cd97a69122279227176d1fdb5f22ff286ca4df1dbea58d5068c0f7ad9d7e SHA512 6c54d1bb7ae233221f01ae32b46c2e5addaa5bc34a7396a599ad30b6c32c3e83ae2fa43792f4989286bd13c854ba133aa80d9051e099b4a50cff21edf13db90a
diff --git a/dev-python/yolk/yolk-0.4.3-r1.ebuild b/dev-python/yolk/yolk-0.4.3-r1.ebuild
index 32decd0f6434..f9ccf8becec6 100644
--- a/dev-python/yolk/yolk-0.4.3-r1.ebuild
+++ b/dev-python/yolk/yolk-0.4.3-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
+
PYTHON_COMPAT=( python2_7 pypy )
inherit distutils-r1
@@ -15,13 +16,16 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="examples"
-DEPEND="dev-python/setuptools
- dev-python/yolk-portage"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/yolk-portage[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
python_install_all() {
+ distutils-r1_python_install_all
+
if use examples; then
docinto examples/plugins
- dodoc -r examples/plugins/*
+ dodoc -r examples/plugins/.
fi
}