summaryrefslogtreecommitdiff
path: root/dev-python/yarl/yarl-1.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-26 12:14:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-26 12:14:51 +0100
commit218cd7b08b8b97198d02f1ba811d540421367139 (patch)
tree8e54a3dcab9a16b30e15a9789d23933365fdd62c /dev-python/yarl/yarl-1.9.2.ebuild
parentd5d36fc823b7189d033e69314ae2764f1eed9168 (diff)
gentoo auto-resync : 26:04:2023 - 12:14:51
Diffstat (limited to 'dev-python/yarl/yarl-1.9.2.ebuild')
-rw-r--r--dev-python/yarl/yarl-1.9.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/yarl/yarl-1.9.2.ebuild b/dev-python/yarl/yarl-1.9.2.ebuild
new file mode 100644
index 000000000000..8cc9f27c1914
--- /dev/null
+++ b/dev-python/yarl/yarl-1.9.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="
+ https://github.com/aio-libs/yarl/
+ https://pypi.org/project/yarl/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+src_configure() {
+ set -- cython -3 yarl/_quoting_c.pyx
+ echo "${*}" >&2
+ "${@}" || die
+}
+
+python_test() {
+ cd tests || die
+ epytest --override-ini=addopts=
+}