summaryrefslogtreecommitdiff
path: root/dev-python/yara-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/yara-python
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/yara-python')
-rw-r--r--dev-python/yara-python/Manifest3
-rw-r--r--dev-python/yara-python/metadata.xml20
-rw-r--r--dev-python/yara-python/yara-python-4.1.3.ebuild29
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/yara-python/Manifest b/dev-python/yara-python/Manifest
new file mode 100644
index 000000000000..73c3cce3c47c
--- /dev/null
+++ b/dev-python/yara-python/Manifest
@@ -0,0 +1,3 @@
+DIST yara-python-4.1.3.tar.gz 33712 BLAKE2B 7878d12620f2834578c98a99bc259422d8ac54efc04ebd29ffa604c15b0462607ce950b3e19f8e80db07195e61dedb4efc8c2ffb18a0c5de0bf2755fe62776d1 SHA512 9c96ae78df7694dd55b8bdde4fad49043f120b94477fa9d7090610665072626eba4fa410cd9292205e0b18bb9f384f07288c0340232e163294b91051b84dcab2
+EBUILD yara-python-4.1.3.ebuild 723 BLAKE2B 8e48ea383239015f2b3ae08028463ec314e4c9666237d8a03c3f321e86cad5336779b2acd6695b075ab951e586764a95750ba3d100b895f7b550b198613e6dc2 SHA512 1968179a083dcad4a3e4b13c795672af700bb8ca634c2e4bf1ffa067c145caf14e934eb4249fbe1daf45569c5a50f3d0fe3e5c98854e63b2d5f38640ab032d2e
+MISC metadata.xml 686 BLAKE2B 47aab79f1d9d1ba937d6dd955647f9a88f85b73d4d033aaebd27b0a404e9423396656a5cafebe2a5b3853b573fca2cdfc0c05b3c7b47654e31a1e58d1fe3ddb2 SHA512 ee02751cd8579395eaba2da6b7d9bfeb02e13d90130d5f9cbd79dc3932c89c19759a2aec51915882f6b6fd7907c3dcb3d8efe02af138bcbb899fbe40abc911c9
diff --git a/dev-python/yara-python/metadata.xml b/dev-python/yara-python/metadata.xml
new file mode 100644
index 000000000000..3deeac8d2e7a
--- /dev/null
+++ b/dev-python/yara-python/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <longdescription>
+ With this library you can use YARA from your Python programs. It covers
+ all YARA's features, from compiling, saving and loading rules to
+ scanning files, strings and processes.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">VirusTotal/yara-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/yara-python/yara-python-4.1.3.ebuild b/dev-python/yara-python/yara-python-4.1.3.ebuild
new file mode 100644
index 000000000000..a8ccc85b7d96
--- /dev/null
+++ b/dev-python/yara-python/yara-python-4.1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface for a malware identification and classification tool"
+HOMEPAGE="https://github.com/VirusTotal/yara-python"
+SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ =app-forensics/yara-$(ver_cut 1-2)*"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_compile() {
+ compile_python() {
+ distutils-r1_python_compile --dynamic-linking
+ }
+ python_foreach_impl compile_python
+}