summaryrefslogtreecommitdiff
path: root/dev-python/yara-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/yara-python
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/yara-python')
-rw-r--r--dev-python/yara-python/Manifest4
-rw-r--r--dev-python/yara-python/yara-python-4.2.0-r2.ebuild (renamed from dev-python/yara-python/yara-python-4.2.0.ebuild)12
2 files changed, 8 insertions, 8 deletions
diff --git a/dev-python/yara-python/Manifest b/dev-python/yara-python/Manifest
index a050e18ae662..f7aff95853a8 100644
--- a/dev-python/yara-python/Manifest
+++ b/dev-python/yara-python/Manifest
@@ -1,3 +1,3 @@
-DIST yara-python-4.2.0.tar.gz 34459 BLAKE2B fce460385eaa75dd1779fe49c7937ff36d7604433deb310b6fe9e66af9ea521952f92bee61829372cf19c7efee170329609530f1f9e863991720e4887c3c1349 SHA512 ba08d709fc51679ec9fe36165e0864b79fc241f85c681bf59823fe7bb0e34e928cded050ff296147eb5bcb837485f39949aa93425a0eb9ca8b3730e60fac93f4
-EBUILD yara-python-4.2.0.ebuild 801 BLAKE2B d3bc9bb4b97035346f9ba9044157e2041c8c6aef42c019fd1e9c96840794d39a60ad65a6a2e15aab7ca1dced6f17c38910633023dfaafca890c26b6c6f13a0e5 SHA512 8704c04cb423c518c454d3128d0fca22aef5b0f1a5481d5bb259e90587801eea38f952eb5624f7434c8894167afaf4d293fba53337e1fc5d3d9bcbec569147ed
+DIST yara-python-4.2.0.gh.tar.gz 34459 BLAKE2B fce460385eaa75dd1779fe49c7937ff36d7604433deb310b6fe9e66af9ea521952f92bee61829372cf19c7efee170329609530f1f9e863991720e4887c3c1349 SHA512 ba08d709fc51679ec9fe36165e0864b79fc241f85c681bf59823fe7bb0e34e928cded050ff296147eb5bcb837485f39949aa93425a0eb9ca8b3730e60fac93f4
+EBUILD yara-python-4.2.0-r2.ebuild 773 BLAKE2B 628b2f73e6c9267383fd174b1cf51b934ce4913a369f4d1b095de44716c3dde86cebcb5144def6c7c06ff474e82aa57d51afa9ba41915907dce8d88d594e783d SHA512 0d379b146930496b2932f319923789d723f00d65586bf0eaa5d51b50a1031522dc4af97b3fa4c26da598c0e8614150cb4ab74e3a79b62b4dfb27ce17471d8a3f
MISC metadata.xml 735 BLAKE2B 43ee6948356d63c37a63a904c1975c0698c5f5db1cc2087108e060a2a0b071900eb6615b8a7a8cea67589cb2dae17cbdd425d2e518785c45aadf490773fe88fa SHA512 d18530850cca51e764c8b3c1575464eabb23beea351d464358ab243dc463b916ed8a28c8ff958ce82486791575343d9be2083f90ab55aa11d342032d0ec1d3f0
diff --git a/dev-python/yara-python/yara-python-4.2.0.ebuild b/dev-python/yara-python/yara-python-4.2.0-r2.ebuild
index c9eca9c95ffd..c812ebe88b86 100644
--- a/dev-python/yara-python/yara-python-4.2.0.ebuild
+++ b/dev-python/yara-python/yara-python-4.2.0-r2.ebuild
@@ -9,7 +9,7 @@ inherit distutils-r1
DESCRIPTION="Python interface for a malware identification and classification tool"
HOMEPAGE="https://github.com/VirusTotal/yara-python"
-SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
@@ -21,11 +21,11 @@ DEPEND="${RDEPEND}"
distutils_enable_tests unittest
-src_compile() {
- compile_python() {
- distutils-r1_python_compile --dynamic-linking
- }
- python_foreach_impl compile_python
+python_configure_all() {
+ cat >> setup.cfg <<-EOF
+ [build_ext]
+ dynamic-linking = True
+ EOF
}
python_test() {