summaryrefslogtreecommitdiff
path: root/dev-python/yara-python/yara-python-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-05 17:25:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-05 17:25:42 +0100
commit4274bed0c1f1fd06a654f5816e30d82059f4cc39 (patch)
treecc4ccd86e6f201e537ac75afd01fd7d620b4085d /dev-python/yara-python/yara-python-9999.ebuild
parentad77dc19e91d2c023f80e11e8974536d80e3a743 (diff)
gentoo auto-resync : 05:04:2023 - 17:25:42
Diffstat (limited to 'dev-python/yara-python/yara-python-9999.ebuild')
-rw-r--r--dev-python/yara-python/yara-python-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/yara-python/yara-python-9999.ebuild b/dev-python/yara-python/yara-python-9999.ebuild
new file mode 100644
index 000000000000..a4fa9fa8737f
--- /dev/null
+++ b/dev-python/yara-python/yara-python-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface for a malware identification and classification tool"
+HOMEPAGE="https://github.com/VirusTotal/yara-python"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/VirusTotal/yara-python.git"
+else
+ SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ =app-forensics/yara-$(ver_cut 1-2)*
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+python_configure_all() {
+ cat >> setup.cfg <<-EOF
+ [build_ext]
+ dynamic_linking = True
+ EOF
+}
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}