summaryrefslogtreecommitdiff
path: root/dev-python/yappi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/yappi
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/yappi')
-rw-r--r--dev-python/yappi/Manifest4
-rw-r--r--dev-python/yappi/yappi-0.98.ebuild4
-rw-r--r--dev-python/yappi/yappi-1.0.ebuild23
3 files changed, 28 insertions, 3 deletions
diff --git a/dev-python/yappi/Manifest b/dev-python/yappi/Manifest
index 249da24d042d..05cf20263135 100644
--- a/dev-python/yappi/Manifest
+++ b/dev-python/yappi/Manifest
@@ -1,3 +1,5 @@
DIST yappi-0.98.tar.gz 37074 BLAKE2B 3a2c60f7c5987681f242230fc4fa0b87f924c0d1dbaedd3c240d30e6c440e2604e7add789cfd37052301a1f0ab99c81e2de30249fd6c83d5ba00624e131d266a SHA512 699e1845aac8e3c701c495913862597240b264c396b0b6ad0e9d6d533138caaeb883baeb036dc7b57bddf02ba411475401b2db77527d2ee63409d73b80f32098
-EBUILD yappi-0.98.ebuild 526 BLAKE2B b3c934bc4c61cc237a5c6a2ad28790acb7d0bfd52f9a82f173456ce4c98eec9a18fb7a18890dcb59dae6cf8e2d924c0eb1fdc022f0f71392a57e31f590c9deaa SHA512 43585719ed44baf95ab99c053804550e5b28e1b4131a0849d3ca54438f214896339383b2ad5e83d1ee034edc8fd140e06cb76219ed08d0c24bac2f9e0398c697
+DIST yappi-1.0.tar.gz 38939 BLAKE2B b07b38bc07ffb6ba7aea3728ba6977680ca7f2dcc499778110aa31e733c512e5704cd580d01faf3344849df6772f110472a01328447228e9c45180beefc36f3e SHA512 d743c471ee3797b9f3b24c831fcb4ddf2cec7c13c56e567c0618eeada9a534ca0b114929da623a2c67142c61f3c38b024b25ba5e32883113148f4377f7574905
+EBUILD yappi-0.98.ebuild 521 BLAKE2B 0b508731e7b48284de71ec6261bb2c1304dadd4424c942f8f4f5787fe2783675f1e0bf8a3546b76fc4fa7d1a9f673e100c80e7a72b759efe5cc1c385145acac6 SHA512 5b453d85eb25e79d531986fe71c074ec22de8610fb312930388dbd66632c4e12b53f0ab8b664aa563b409a18546c269d8f9577acc236a4d3d73a534fd5f25f2e
+EBUILD yappi-1.0.ebuild 530 BLAKE2B 91adaaac7c2807831274cdabbf373393e0892d1541bd974345c3324187498633e1ed574551b8544c21c3c9d575c30b30c6c14d14b2c64850ca2b764e7ce854ae SHA512 3f1fefb5901d5b32ef950c3e73ab3ba7bc38c74e6d38b5e59219bfd5eef775db2a7609dbd1fa0e72be7eb7b2b2846acb484dca0d0da1ad8524aaddc1b187a74d
MISC metadata.xml 491 BLAKE2B bd3b3283c39af67f7a1f55891d3168bf6bc054052007bec6303016d3f6b513cd20f94c83f427cd849b951102085b390e69dd4ac2d2d44a6b31bb5f1ff3f10af1 SHA512 d058a5d7d593e801967cbd8764ce0e55480580995a68cd3d35802932249fa015267052895d360fc13cda379333d1cf8222e02f486e68477afe1e2af1168731fc
diff --git a/dev-python/yappi/yappi-0.98.ebuild b/dev-python/yappi/yappi-0.98.ebuild
index 3a009d3ce1bc..32b4a8f02a91 100644
--- a/dev-python/yappi/yappi-0.98.ebuild
+++ b/dev-python/yappi/yappi-0.98.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=(python{2_7,3_{4,5,6}})
+PYTHON_COMPAT=(python{2_7,3_{5,6}})
inherit distutils-r1
DESCRIPTION="Yet Another Python Profiler"
diff --git a/dev-python/yappi/yappi-1.0.ebuild b/dev-python/yappi/yappi-1.0.ebuild
new file mode 100644
index 000000000000..7a8e183156f8
--- /dev/null
+++ b/dev-python/yappi/yappi-1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_{5,6,7}})
+inherit distutils-r1
+
+DESCRIPTION="Yet Another Python Profiler"
+HOMEPAGE="https://bitbucket.org/sumerc/yappi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}