summaryrefslogtreecommitdiff
path: root/dev-python/yappi/files/yappi-1.2.5-warnings.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/yappi/files/yappi-1.2.5-warnings.patch
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/yappi/files/yappi-1.2.5-warnings.patch')
-rw-r--r--dev-python/yappi/files/yappi-1.2.5-warnings.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-python/yappi/files/yappi-1.2.5-warnings.patch b/dev-python/yappi/files/yappi-1.2.5-warnings.patch
new file mode 100644
index 000000000000..1594c33ee3d2
--- /dev/null
+++ b/dev-python/yappi/files/yappi-1.2.5-warnings.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index cd9a549..440043c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -23,7 +23,7 @@ link_args = []
+
+ if os.name == 'posix' and sys.platform != 'darwin':
+ compiler = new_compiler()
+- if compiler.has_function('timer_create', libraries=('rt', )):
++ if compiler.has_function('timer_create', libraries=('rt', ), includes=["signal.h", "time.h"]):
+ user_macros.append(('LIB_RT_AVAILABLE', '1'))
+ user_libraries.append('rt')
+ if _DEBUG: