summaryrefslogtreecommitdiff
path: root/dev-python/yamlpath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-03 03:10:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-03 03:10:55 +0000
commit670a2ef95331c60f32a0831bfe79445340356b0b (patch)
treecca4590ecf2c13488c7ef6c478f3e49acec2922d /dev-python/yamlpath
parentd05150f06fa67b115a83f822b1e285dca011e1b7 (diff)
gentoo auto-resync : 03:11:2022 - 03:10:55
Diffstat (limited to 'dev-python/yamlpath')
-rw-r--r--dev-python/yamlpath/Manifest2
-rw-r--r--dev-python/yamlpath/yamlpath-3.6.8.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/yamlpath/Manifest b/dev-python/yamlpath/Manifest
index e35b8de02b7a..1b50d9d08562 100644
--- a/dev-python/yamlpath/Manifest
+++ b/dev-python/yamlpath/Manifest
@@ -1,3 +1,5 @@
DIST yamlpath-3.6.7.gh.tar.gz 219770 BLAKE2B 779b94f6aff7e6430c89508145d85d2b7b5ddb4bc1070fd68d402e27b7bf596c7e68f1bfb8683791ea2572ef6d01fe5f2de4fd646be32b8ab266747371f61f36 SHA512 7313d3eaa9268d4c2acb1bc87052068498840943be503fa160833c03f372e5c6d7604572d277b70c551784fd8c9507e084f12dd651b5c4f600f69e8ee7cefb62
+DIST yamlpath-3.6.8.gh.tar.gz 220132 BLAKE2B dc2b3c54d6e09e1d273643fa52f7079c2734eda2145a9e31cda3c5f6ff20d5e423fae7228297849a78fc7539f0865fabbb4640c9520e280e58b28dab52eee89f SHA512 6e5e43e6a25cfaf4bd7618b3e84baf6ca1cf33bd2c0f6c5ce3f58c5f22e64728610f1bb462901f8b6bd8fe2ca3b5265624e72cc8958ffdd0c612dcccfef8bc7a
EBUILD yamlpath-3.6.7.ebuild 1156 BLAKE2B eb66fdcd37a5ebf94857f9b26ec435a39cb70d854ac015a9b121151765a41d4132de395aef370eed51a40992cd801900a503eb95c979d921f5bc87302a374c43 SHA512 03798242ce9f91e09eb4f38b2c11fb84248b8da886f32564f4a0c3c51565580d5b79eddec42701c80a201521b00a9e6094c3d4e6223ea6197d970aae08ea64f7
+EBUILD yamlpath-3.6.8.ebuild 1156 BLAKE2B eb66fdcd37a5ebf94857f9b26ec435a39cb70d854ac015a9b121151765a41d4132de395aef370eed51a40992cd801900a503eb95c979d921f5bc87302a374c43 SHA512 03798242ce9f91e09eb4f38b2c11fb84248b8da886f32564f4a0c3c51565580d5b79eddec42701c80a201521b00a9e6094c3d4e6223ea6197d970aae08ea64f7
MISC metadata.xml 664 BLAKE2B cdf919f6a46dbc7ed8f2546509a623e0e784da711afaade20ec79b2861e8c83f54f755ce68ec2944bd0edb92f2e05b18a9c0ff93430c185574c41de2d789e03d SHA512 8020ca58f464e2aed71c01c29375b95dda238be6cdb94468a0abe50c7ce0270a42d723318f34cb4eb8728184cbe6769c7e666f43cffde37e6e9f42cab4d7292e
diff --git a/dev-python/yamlpath/yamlpath-3.6.8.ebuild b/dev-python/yamlpath/yamlpath-3.6.8.ebuild
new file mode 100644
index 000000000000..e236b9aeee0e
--- /dev/null
+++ b/dev-python/yamlpath/yamlpath-3.6.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Command-line processors for YAML/JSON/Compatible data"
+HOMEPAGE="https://github.com/wwkimball/yamlpath https://github.com/wwkimball/yamlpath/wiki"
+SRC_URI="
+ https://github.com/wwkimball/yamlpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-ruby/hiera-eyaml
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ sed -e '/ruamel\.yaml/d' \
+ -e '/pytest-cov/d' \
+ -e "/find_packages/s/()/(exclude=\['tests'\])/" \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # install and optimize yamlpath/patches/aliasstyle.py
+ local sitedir=$(python_get_sitedir)
+ [[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
+ insinto "${sitedir}/yamlpath"
+ doins -r "${S}/yamlpath/patches"
+ python_optimize "${D}${sitedir}"
+}