summaryrefslogtreecommitdiff
path: root/dev-python/xxhash/xxhash-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/xxhash/xxhash-2.0.0.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/xxhash/xxhash-2.0.0.ebuild')
-rw-r--r--dev-python/xxhash/xxhash-2.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/xxhash/xxhash-2.0.0.ebuild b/dev-python/xxhash/xxhash-2.0.0.ebuild
new file mode 100644
index 000000000000..ea7b6e71a9a1
--- /dev/null
+++ b/dev-python/xxhash/xxhash-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6..8})
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding for the xxHash library"
+HOMEPAGE="https://github.com/ifduyue/python-xxhash
+ https://pypi.org/project/xxhash/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-libs/xxhash-0.8.0"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+python_configure_all() {
+ export XXHASH_LINK_SO=1
+}
+
+python_test() {
+ cd tests
+ "${EPYTHON}" -m unittest discover -v || die "tests failed with ${EPYTHON}"
+}