summaryrefslogtreecommitdiff
path: root/dev-python/xstatic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/xstatic
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/xstatic')
-rw-r--r--dev-python/xstatic/Manifest3
-rw-r--r--dev-python/xstatic/metadata.xml11
-rw-r--r--dev-python/xstatic/xstatic-1.0.1.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/xstatic/Manifest b/dev-python/xstatic/Manifest
new file mode 100644
index 000000000000..45a8abfe1e05
--- /dev/null
+++ b/dev-python/xstatic/Manifest
@@ -0,0 +1,3 @@
+DIST xstatic-1.0.1.tar.gz 2588 BLAKE2B 55e937e62cb845a9095d41b42b484d740557681f4b811522093c6486d97b9e5daa3d12af953bc24a37ed39df58d3adad1cb578ca434b8c0cf0ab4f4b23fff0ff SHA512 03b227a5971959c79c6b389d3bd1f6db724a439101599b8ae65b7d010712184308e30377125bbf24ce84994aa6e9add3d462fba9bee0008154d3753d3199040f
+EBUILD xstatic-1.0.1.ebuild 630 BLAKE2B 33fc3786ca0f4dbae40989efea6ea5f28c280dab2cc1da6062158c94a261473feec38593efa03ca16b0d8577442f0360d00f5946fe3849f971654f674f4ae158 SHA512 1a74ee91eb64692db83ab24ed3aedc999e040d14317b5c89f334602221b4ec9505ef6af4e43c51ecb4aa03d269fcb4b7300cfe910587a775382d25d49a751493
+MISC metadata.xml 328 BLAKE2B cd1db5ebb236344ab7336b3db5f4523fc3730a99a294392907ee5289a17feffd31390be088c02aa6c87a84bbbebd84bb48482cd739a5f55303333083d4bdc0c0 SHA512 883210945f38216a48fa5166057e95aafa03c9aec5a7de0d16303fb6a4e6d98c22695b55dd5fc1d26ba78b7c3def32ac7bfce1f036db32116a9b4e5e0b31a8c8
diff --git a/dev-python/xstatic/metadata.xml b/dev-python/xstatic/metadata.xml
new file mode 100644
index 000000000000..8768d46bf628
--- /dev/null
+++ b/dev-python/xstatic/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">XStatic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/xstatic/xstatic-1.0.1.ebuild b/dev-python/xstatic/xstatic-1.0.1.ebuild
new file mode 100644
index 000000000000..d529011eddab
--- /dev/null
+++ b/dev-python/xstatic/xstatic-1.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="XStatic"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XStatic base package with minimal support code"
+HOMEPAGE="https://pypi.org/project/XStatic"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install() {
+ distutils-r1_python_install
+ find "${ED}" -name '*.pth' -delete || die
+}