summaryrefslogtreecommitdiff
path: root/dev-python/xmlschema
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/xmlschema
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest3
-rw-r--r--dev-python/xmlschema/metadata.xml7
-rw-r--r--dev-python/xmlschema/xmlschema-1.0.16.ebuild31
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
new file mode 100644
index 000000000000..96b06432f167
--- /dev/null
+++ b/dev-python/xmlschema/Manifest
@@ -0,0 +1,3 @@
+DIST xmlschema-1.0.16.tar.gz 278082 BLAKE2B 284f71536f86475fbfccefe1130fbea9319282e34ec11a1ca13c6ddd0f8aad2747d66c8cc6443885982c6f98fa074778f2757d012d1380ae46136dc3e5df4a69 SHA512 5dd79e608036995d70b4da627f89c86cd8e7a66f80c2cb87d701395229daa920759769bf7efad34c33dd28ca14971eb155a654f8fec12fb6ace8cb5ecf979650
+EBUILD xmlschema-1.0.16.ebuild 785 BLAKE2B 205974d58f8a9ed656821bc199c9eb0e56b9b7740542036936fdff1044813dc9e9b8c875717c74637383afa70e6cb19b517781116d5437207370adbb71ec1f66 SHA512 6a80f08d9100dfd16630ebdcc07f578ea8d733744072720aa8236260e67ad6522fb345ee498187c64b4db53d6fb9fc9d687147408a1b26dd6ce3eb2acd22a14b
+MISC metadata.xml 218 BLAKE2B 086fdcf7b63ca7bd6c58e861d717bb375e1cd372eff26d5d2eeeb176d8c5e6f10e653562abafb50eae7d7508f8e3d421b87e6a749acd0490308672828d0da697 SHA512 4558fee4c51117e21b1f42ca3edbdf1195ed297db798d6bfa0e5fbb7019654a187422b0abde7af5d800caffed66d1e55e4280e8be602bad591424d9776c46781
diff --git a/dev-python/xmlschema/metadata.xml b/dev-python/xmlschema/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/xmlschema/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/xmlschema/xmlschema-1.0.16.ebuild b/dev-python/xmlschema/xmlschema-1.0.16.ebuild
new file mode 100644
index 000000000000..26c6d0fdbab8
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.0.16.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/elementpath[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
+ )"
+
+python_test() {
+ "${EPYTHON}" xmlschema/tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}