summaryrefslogtreecommitdiff
path: root/dev-python/xmlschema/xmlschema-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-22 02:45:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-22 02:45:48 +0100
commit52fc263f2dd029a99ad4f0e5e1c3dbfd490d6b63 (patch)
treef00cbd5f2bd3b202f000a03fb3beb1742890f144 /dev-python/xmlschema/xmlschema-2.0.1.ebuild
parentaa870ba91722a8d38ba5103297a6aa4abb54e5bc (diff)
gentoo auto-resync : 22:07:2022 - 02:45:47
Diffstat (limited to 'dev-python/xmlschema/xmlschema-2.0.1.ebuild')
-rw-r--r--dev-python/xmlschema/xmlschema-2.0.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/xmlschema/xmlschema-2.0.1.ebuild b/dev-python/xmlschema/xmlschema-2.0.1.ebuild
new file mode 100644
index 000000000000..da14b0a0f004
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-2.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="
+ https://github.com/sissaschool/xmlschema/
+ https://pypi.org/project/xmlschema/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/elementpath-4[${PYTHON_USEDEP}]
+ >=dev-python/elementpath-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}