summaryrefslogtreecommitdiff
path: root/dev-python/xlsxwriter/xlsxwriter-1.3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/xlsxwriter/xlsxwriter-1.3.5.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/xlsxwriter/xlsxwriter-1.3.5.ebuild')
-rw-r--r--dev-python/xlsxwriter/xlsxwriter-1.3.5.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/xlsxwriter/xlsxwriter-1.3.5.ebuild b/dev-python/xlsxwriter/xlsxwriter-1.3.5.ebuild
new file mode 100644
index 000000000000..0976f9f9d2f1
--- /dev/null
+++ b/dev-python/xlsxwriter/xlsxwriter-1.3.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="XlsxWriter"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python module for creating Excel XLSX files"
+HOMEPAGE="https://github.com/jmcnamara/XlsxWriter"
+SRC_URI="https://github.com/jmcnamara/XlsxWriter/archive/RELEASE_${PV}.tar.gz -> ${P}-tests.tar.gz"
+S="${WORKDIR}/${MY_PN}-RELEASE_${PV}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest