summaryrefslogtreecommitdiff
path: root/dev-python/xlsxwriter/xlsxwriter-0.7.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/xlsxwriter/xlsxwriter-0.7.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/xlsxwriter/xlsxwriter-0.7.8.ebuild')
-rw-r--r--dev-python/xlsxwriter/xlsxwriter-0.7.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/xlsxwriter/xlsxwriter-0.7.8.ebuild b/dev-python/xlsxwriter/xlsxwriter-0.7.8.ebuild
new file mode 100644
index 000000000000..30ac84f26f1e
--- /dev/null
+++ b/dev-python/xlsxwriter/xlsxwriter-0.7.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="XlsxWriter"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python module for creating Excel XLSX files"
+HOMEPAGE="https://pypi.python.org/pypi/XlsxWriter https://github.com/jmcnamara/XlsxWriter"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}"/${MY_P}
+
+# Missing from tarball
+# https://github.com/jmcnamara/XlsxWriter/issues/327
+RESTRICT=test
+
+python_test() {
+ nosetests --verbosity=3 || die
+}