summaryrefslogtreecommitdiff
path: root/dev-python/xdoctest/xdoctest-1.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 08:44:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 08:44:00 +0100
commit1e8bc3b2037289b8577740cea9321c37c52a49a2 (patch)
treeeb73b737abc04c27ce7e878f621e1a49deb09857 /dev-python/xdoctest/xdoctest-1.1.2.ebuild
parentc3a905eafd0ea87d50767fa3d24a6b565a41faa9 (diff)
gentoo auto-resync : 26:10:2023 - 08:43:59
Diffstat (limited to 'dev-python/xdoctest/xdoctest-1.1.2.ebuild')
-rw-r--r--dev-python/xdoctest/xdoctest-1.1.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/xdoctest/xdoctest-1.1.2.ebuild b/dev-python/xdoctest/xdoctest-1.1.2.ebuild
new file mode 100644
index 000000000000..5a3da3c3559a
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-1.1.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="
+ https://github.com/Erotemic/xdoctest/
+ https://pypi.org/project/xdoctest/
+"
+SRC_URI="
+ https://github.com/Erotemic/xdoctest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+#distutils_enable_sphinx docs/source \
+# dev-python/autoapi \
+# dev-python/sphinx-rtd-theme
+
+EPYTEST_DESELECT=(
+ tests/test_pytest_cli.py::test_simple_pytest_import_error_cli
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdoctest.plugin
+
+ epytest --pyargs tests xdoctest
+}