summaryrefslogtreecommitdiff
path: root/dev-python/xdoctest/xdoctest-0.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/xdoctest/xdoctest-0.15.0.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/xdoctest/xdoctest-0.15.0.ebuild')
-rw-r--r--dev-python/xdoctest/xdoctest-0.15.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/xdoctest/xdoctest-0.15.0.ebuild b/dev-python/xdoctest/xdoctest-0.15.0.ebuild
deleted file mode 100644
index 31a5c28a79e7..000000000000
--- a/dev-python/xdoctest/xdoctest-0.15.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
-HOMEPAGE="https://github.com/Erotemic/xdoctest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
-
-python_prepare_all() {
- # fails because the ebuild environment location is not the expected location
- sed -i -e 's:test_xdoc_console_script_location:_&:' \
- testing/test_entry_point.py || die
-
- # xdoctest has to be in PATH for this to work
- sed -i -e 's:test_xdoc_console_script_exec:_&:' \
- testing/test_entry_point.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- PYTHONPATH="${WORKDIR}/${P}"
- pytest -vv || die "Test fail with ${EPYTHON}"
-}