summaryrefslogtreecommitdiff
path: root/dev-python/xcffib/xcffib-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /dev-python/xcffib/xcffib-0.8.1.ebuild
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'dev-python/xcffib/xcffib-0.8.1.ebuild')
-rw-r--r--dev-python/xcffib/xcffib-0.8.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/xcffib/xcffib-0.8.1.ebuild b/dev-python/xcffib/xcffib-0.8.1.ebuild
new file mode 100644
index 000000000000..528b8913b976
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="https://github.com/tych0/xcffib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="x11-libs/libxcb"
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ dev-python/six[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+ x11-apps/xeyes
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-test-imports.patch )
+
+python_test() {
+ virtx nosetests -d -v || die
+}