summaryrefslogtreecommitdiff
path: root/dev-python/xarray
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-23 18:45:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-23 18:45:51 +0000
commit3bd958e646e508a3e80f5fb28f44384eed671f5d (patch)
tree59c64eff7f35adeaabe15243171164094a9c23e1 /dev-python/xarray
parentc8c3804588db08dae281504dd79ef71741cd8dc3 (diff)
gentoo auto-resync : 23:03:2023 - 18:45:51
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest2
-rw-r--r--dev-python/xarray/xarray-2023.3.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index 94267c928532..94b9e56bf8b7 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,5 +1,7 @@
DIST xarray-2022.12.0.tar.gz 3060755 BLAKE2B 449d21234436983b478a022cf5585236738014c6f783039442c3d51870b62a62c61eaada6eb9df5305ada3fd5cdc87bf0201ffae1c835ec7a731c06badb718a7 SHA512 9c5c692392b15711d57254006ebc92cdda08b92b663a577701f50c52253d736d78e2ad027777ad588ffa23d523394576f0cf226986b05b22816d3cec1ea8abb7
DIST xarray-2023.2.0.tar.gz 3070514 BLAKE2B 00b08bb75878eed1aa82ac18ae5bc468d87812c90991f95b238048d53535dd884a943a068aec4114ba83c8e3cf1a37570b86ce5557fb33dc43f088a51916b92d SHA512 46b1e29e98a7c1bbe3275bc2fd39b0e5561319b4b9c6bf468c434880c9013c1dd9560b7281bd1b148ba8557cafe91ddf0ac56e5c038f1e995067ff1774162ab2
+DIST xarray-2023.3.0.tar.gz 3686167 BLAKE2B b9c2e04d0278e383aef17280e74863244d458324c01ac59a453e72196d65cad8fbca9f8f99a33b6db66637f742e04e5615fa8fc6eed307f0511954a856f8f3d2 SHA512 c08269e6fc8cdd3123dd7c39e0b85959bafdc53a5da75187fc615281fb71212bf2e45059f8d18fa05339567a4827e7bb68de3e605416929a6a1defdb4ed393e3
EBUILD xarray-2022.12.0.ebuild 1224 BLAKE2B 73639accd1ff4d7cd1367b75f21fdc60f0314f384fd42125852bb2781bff1342d898d1d29aff7f8abcf4678f1921159eb73184cf1569c07a909b54a9dd813870 SHA512 8bb63e3eea10d0da44533200dcba0a479afa6782c1f6a4f7addf40d4613539e74f9d6d9462f1e35ceda66cbce9795e23b45e97ac340138856b910d75d569d7c6
EBUILD xarray-2023.2.0.ebuild 1180 BLAKE2B 9cd26462f86e6b4235d82710ad2ddb0ae5c3eb5351dedd7d49155682a9dadfb0e973afca606ffe3838b02830c0399d6765a04f6cd94a20b51c497ee263212fee SHA512 acbb844f26645b3eed4503c855160d90a5df4db6d3ee709f9d19aa3b3830b6286a8e78c649b506f1c7fbeee43d09c30fe1f9390565744809244f2e7d210dcdb5
+EBUILD xarray-2023.3.0.ebuild 1224 BLAKE2B fb7b48af1ac04366407e8f1243b82cac478898e0f233879e0b8ddb8ecc7ffc99962019e31b4b491ba408c28efc8498a38f85be42c6c517618764b2f0461cbef4 SHA512 e0cbe0459854610dab551ac248fc79e397356e6048898e1ada87cb886c22d97d66dea71cbc8c9793e64120cd1d08b5c5a63fc893227e017f1412409eaafda806
MISC metadata.xml 509 BLAKE2B d470cc092eb055215a5868c22f9ec458057cfad600357fa1f658ed4537a6a6f68bda1422c4a665f1963ce0a6049e691befc3ca4baa60cc898364ad5f18164979 SHA512 602755896a3655295058afc8543a4bb64192d5c625f2edd86291c1f23d171f051a4238466163c2d469874aff3e68770fc76177e720870492266fb14e6faf6ce7
diff --git a/dev-python/xarray/xarray-2023.3.0.ebuild b/dev-python/xarray/xarray-2023.3.0.ebuild
new file mode 100644
index 000000000000..cc0d2354ba87
--- /dev/null
+++ b/dev-python/xarray/xarray-2023.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="
+ https://xarray.pydata.org/
+ https://github.com/pydata/xarray/
+ https://pypi.org/project/xarray/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ <dev-python/pandas-2[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+)