summaryrefslogtreecommitdiff
path: root/dev-python/xarray
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-14 07:43:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-14 07:43:49 +0100
commitfe8b106bd60ab72e98ab836f5c702070805e197e (patch)
tree44016d57867c58de87efd4b028c171d352bbf3be /dev-python/xarray
parent30737dc88991519b90363c2c7bae8fd049098d13 (diff)
gentoo auto-resync : 14:10:2022 - 07:43:49
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest2
-rw-r--r--dev-python/xarray/xarray-2022.10.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index d470c069764c..d1d26c770364 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,5 +1,7 @@
+DIST xarray-2022.10.0.tar.gz 3035596 BLAKE2B f42df85bdfa66403826fc7d2fa811419898134723ee24afc6b77a320b23c9b5b95fcfd25520f74abf0a3b7bf009fdc33655eebf0ff9703753872072515deee58 SHA512 ecfc92c68ea7ba02b673c6c317e68daad23b6882b4ed316ad1dd733f179c643411d3ee5902954dbd62f2eb7ad591d8ba1a5f0c1b2c7f6873e733df2f22b6650c
DIST xarray-2022.6.0.tar.gz 3013166 BLAKE2B 4f2c17595ec904508e5f9c1d6ffead45be527b7f2ab73383126d57c7894712e924b605a86f890b0fec4ff45d1a263ce27fa324febf83f703ad36079e68f69663 SHA512 415bd84246d6d2b8aebf316ac9ef82ca7afeacce718349b75479c0aa693e2866dfe236e6dcaf41cae68afd7a99408f5027c938e6b7f447f5323e076b804f5165
DIST xarray-2022.9.0.tar.gz 3030815 BLAKE2B 71bea98d49fa9ce2e8e881bdcba7872293e1cd9fa4bd23e6cdce40220d87550fade52a7b7c25ff5d0b11b8a729c57ed219031b1f13d1f375c5278ecc611dfbc5 SHA512 57383cfc809b26d743c06eb5a158d318c65aedfa374e62b0a5fdc99708632a364b2efb6275fbc728e441effb7c695635a443cf141d69fa742216a677f4168b3b
+EBUILD xarray-2022.10.0.ebuild 1113 BLAKE2B 7c6c9efa34384aea2c7bbcc0f263d2b5fd4eff771a5e3eeca5bced653384d635e22863da38011c6f3875e6eee169cb1e75e52d689b2a42b810e6ccc4b16b9709 SHA512 20a3143028e3c8d42e881cc9bf0c286df66f5a79e1f30b8d956b7579ffaef5a13064e9ec61737ea45689fc779ae51377bbf9e81692fa57182cece4a7c86aee8f
EBUILD xarray-2022.6.0.ebuild 1100 BLAKE2B 69026f76a222a1c1f6f4a52dbadd28d70154c6355fa8b21541697a9859716b566264d44f9ff8819705251556337dbb84588859e4f18ceb474e72b0502ef11006 SHA512 5ad0633eff44291cacb14c40477944ddbcdbcee1ad7d618c5b677bbc409912b4be064c00814b2ce21f542dfd1056050b7f4384b38d45fa395f0d6c0ce42b40bd
EBUILD xarray-2022.9.0.ebuild 1106 BLAKE2B 42f7907525a13a7051e1d7d801df654b04b696a4bcc54254898bd3e4a70d8892d8ca1747e63e1c67ee1aae50142219d3f15c2cff97f92d7af61f919f8d0b824f SHA512 f11c67003d20f5e6dcd9990773653c9baf9fe6ca00d65b462f7e01055186a1352fd7fc5eb9fb968eb889b36cd83fb1ae680fae0740c6f119360ed7a2950084ff
MISC metadata.xml 509 BLAKE2B d470cc092eb055215a5868c22f9ec458057cfad600357fa1f658ed4537a6a6f68bda1422c4a665f1963ce0a6049e691befc3ca4baa60cc898364ad5f18164979 SHA512 602755896a3655295058afc8543a4bb64192d5c625f2edd86291c1f23d171f051a4238466163c2d469874aff3e68770fc76177e720870492266fb14e6faf6ce7
diff --git a/dev-python/xarray/xarray-2022.10.0.ebuild b/dev-python/xarray/xarray-2022.10.0.ebuild
new file mode 100644
index 000000000000..5ce78ec96b6d
--- /dev/null
+++ b/dev-python/xarray/xarray-2022.10.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="https://xarray.pydata.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.0[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+)