summaryrefslogtreecommitdiff
path: root/dev-python/xarray
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/xarray
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest4
-rw-r--r--dev-python/xarray/xarray-0.18.1.ebuild42
-rw-r--r--dev-python/xarray/xarray-0.18.2.ebuild42
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index 4be4ac472b30..e8e3de7ef9cb 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,3 +1,7 @@
DIST xarray-0.17.0.tar.gz 2055584 BLAKE2B afbd28032069e4b498c87abd34661dc96525cb581a08fcf68eeaca08468afb9b452650bce4d21cada0eb1cb75ad11b0565a6b965b11120d4bef4d4cd612fa91d SHA512 726d548519614936f4b6c6ded0375a35362b195a2c6b55a282d198cbb8a70fa7439377a88f253cf4f16c86582fc22c8a4700b9645516decf7edd3e980d9dda34
+DIST xarray-0.18.1.tar.gz 2849935 BLAKE2B f4d510a049e67431737ba7f6a66fdd83061e6e5728ac6bfd3b9f104b24cc619cb1d0f05bbe6911e952c312ef229dbf1a68842b75dbb0ecf811fcc7d6e78569b0 SHA512 e1842d7bf06ee23716038fd58e7ae3a2014012cbc49394c9000272cb0498c1d333cbf3133b1d8fcdbddd524d44f6fa5fcc117c992d0ab1d3d0b9c4ddfc317847
+DIST xarray-0.18.2.tar.gz 2850065 BLAKE2B 16d8f5e10a7c9cb4247a3bc8f496f249d66235673e79d0707077e20b54a7d94a7b754fb00f44b876fa21273521f9e2e7d52183798ca33b8e62b30fbc57621c5a SHA512 3cfd6a3b77c48a73eb72e6c39db33aba266925df7ce9b8270231dd14032a717094073a2c3686b09fcff25313b548a452f9ed902211e254254389d15f025d8d0d
EBUILD xarray-0.17.0.ebuild 1090 BLAKE2B 95aa23f92a87a18dfbb8eafb225bb00ad0d8803d153bf6dbc7c14d2098bd396f2a423642c7f0dd55b0ae3a4a0f9d0c91c4e07470e2c35b9a6d7860cf3e437a43 SHA512 7b1774d9f94f1510d3e470e4a887a8bdb9986a4a4825d42737adb45492b5701f678da43ad8f4466d52ee28a1847f7470653fe042185be7bdb950319512f36fb9
+EBUILD xarray-0.18.1.ebuild 1092 BLAKE2B eeaa65c52f8cb7d9c8abce710e7402fc3647484cf288189dd3561c5f6e7e865a2b01c75525943dc18696877b7c164205b091d08d8e2e24f77b037b024d322f72 SHA512 6d4fc469c4878ebc65a4b1681e402f0e6363b524b1fdd59fdf36a449e22f5c8c54d0847d38a1d557f0f79a23b532b2bef68c7ae5a799a598162c774dff9086e9
+EBUILD xarray-0.18.2.ebuild 1092 BLAKE2B eeaa65c52f8cb7d9c8abce710e7402fc3647484cf288189dd3561c5f6e7e865a2b01c75525943dc18696877b7c164205b091d08d8e2e24f77b037b024d322f72 SHA512 6d4fc469c4878ebc65a4b1681e402f0e6363b524b1fdd59fdf36a449e22f5c8c54d0847d38a1d557f0f79a23b532b2bef68c7ae5a799a598162c774dff9086e9
MISC metadata.xml 508 BLAKE2B 173d15b73f7a3566c657ebf266b60c4c5b8b92e120fe5eac24bc7fc56faaf9378812386506914372aa9b65e49decd11e1f0e55b33ae41b1c51cda2a20f1bd23c SHA512 988742c143bbcd35de2bd649c72eb8db09f3310014b9a93033e383e1c8c6e799492616216b8389f272e46aa2afe925279550094049b9df2850f1fa78b6071966
diff --git a/dev-python/xarray/xarray-0.18.1.ebuild b/dev-python/xarray/xarray-0.18.1.ebuild
new file mode 100644
index 000000000000..f797bf1c514c
--- /dev/null
+++ b/dev-python/xarray/xarray-0.18.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# pkg_resources use in code
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="https://xarray.pydata.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.0[${PYTHON_USEDEP}]"
+# note: most of test dependencies are optional
+BDEPEND="
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}
diff --git a/dev-python/xarray/xarray-0.18.2.ebuild b/dev-python/xarray/xarray-0.18.2.ebuild
new file mode 100644
index 000000000000..f797bf1c514c
--- /dev/null
+++ b/dev-python/xarray/xarray-0.18.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# pkg_resources use in code
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="https://xarray.pydata.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.0[${PYTHON_USEDEP}]"
+# note: most of test dependencies are optional
+BDEPEND="
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}