summaryrefslogtreecommitdiff
path: root/dev-python/xarray
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-15 17:48:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-15 17:48:43 +0100
commit6fc112778f70ed827633ff345036db5b592ca1d0 (patch)
treee7cdb999d63c6c05d692df24f69651b737792c56 /dev-python/xarray
parent04fc7f10cec12efb1240344a0090b539e24ad0f3 (diff)
gentoo auto-resync : 15:04:2023 - 17:48:43
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest2
-rw-r--r--dev-python/xarray/xarray-2023.4.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index ebf1bbb7f575..5bfc5e3b75ed 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,5 +1,7 @@
DIST xarray-2023.2.0.tar.gz 3070514 BLAKE2B 00b08bb75878eed1aa82ac18ae5bc468d87812c90991f95b238048d53535dd884a943a068aec4114ba83c8e3cf1a37570b86ce5557fb33dc43f088a51916b92d SHA512 46b1e29e98a7c1bbe3275bc2fd39b0e5561319b4b9c6bf468c434880c9013c1dd9560b7281bd1b148ba8557cafe91ddf0ac56e5c038f1e995067ff1774162ab2
DIST xarray-2023.3.0.tar.gz 3686167 BLAKE2B b9c2e04d0278e383aef17280e74863244d458324c01ac59a453e72196d65cad8fbca9f8f99a33b6db66637f742e04e5615fa8fc6eed307f0511954a856f8f3d2 SHA512 c08269e6fc8cdd3123dd7c39e0b85959bafdc53a5da75187fc615281fb71212bf2e45059f8d18fa05339567a4827e7bb68de3e605416929a6a1defdb4ed393e3
+DIST xarray-2023.4.0.tar.gz 3689883 BLAKE2B 50c5a18eaf28fc3bc38bc322dc393ec3e6a66c2651341019b389ba950c01f3950ee13e0922568f29ac1e3650ca9fdb55aec5574abe8f733959f15151208ac09b SHA512 1bb5052cb48e4ecb2d4e9d88cb0a0d3b25469b762d34059b5f65a88c2cbd125711d9af8a46a16b3eff3783f7d7653118b44503f19512ebc89845449a92efe1d9
EBUILD xarray-2023.2.0.ebuild 1178 BLAKE2B bec6155037d99a0832d283af7d5ceff48a51aedebe5baab14f293008ea31903dc9029a82992e1be0399c9102106c6db776009e1f10a30c0a7304bba6cc96eaf6 SHA512 34cba8d8521f7b8506c6b84804365397974f97a71cb8ddfedbdd7f0dc4f11e7b5bfa1e8216a73ec8aa1c7bac7beded74088cd5db283dee76f67380c56b4f65ea
EBUILD xarray-2023.3.0.ebuild 1224 BLAKE2B fb7b48af1ac04366407e8f1243b82cac478898e0f233879e0b8ddb8ecc7ffc99962019e31b4b491ba408c28efc8498a38f85be42c6c517618764b2f0461cbef4 SHA512 e0cbe0459854610dab551ac248fc79e397356e6048898e1ada87cb886c22d97d66dea71cbc8c9793e64120cd1d08b5c5a63fc893227e017f1412409eaafda806
+EBUILD xarray-2023.4.0.ebuild 1737 BLAKE2B cc338022ae7e4b78a4bfe092810ea71f94e5ebd2d768be293be71e87561273e0ea86bb2f90495540989c604b23ba50ca9de6e6ef1bfb5d4ea34ac534ea45c630 SHA512 82477cffbfbe309882ac31e918de8bc87333a19b84fce86811f17a129e97a37e07907b54e67ec87abc849febb7c8ac844d9fbd4512444318ab4a7a95e9fe0a31
MISC metadata.xml 509 BLAKE2B d470cc092eb055215a5868c22f9ec458057cfad600357fa1f658ed4537a6a6f68bda1422c4a665f1963ce0a6049e691befc3ca4baa60cc898364ad5f18164979 SHA512 602755896a3655295058afc8543a4bb64192d5c625f2edd86291c1f23d171f051a4238466163c2d469874aff3e68770fc76177e720870492266fb14e6faf6ce7
diff --git a/dev-python/xarray/xarray-2023.4.0.ebuild b/dev-python/xarray/xarray-2023.4.0.ebuild
new file mode 100644
index 000000000000..41b878f2455d
--- /dev/null
+++ b/dev-python/xarray/xarray-2023.4.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="
+ https://xarray.pydata.org/
+ https://github.com/pydata/xarray/
+ https://pypi.org/project/xarray/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ # TODO: segv in netcdf4-python
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-None]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-None]'
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist.plugin -n "$(makeopts_jobs)"
+}