summaryrefslogtreecommitdiff
path: root/dev-python/xarray/xarray-2022.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-14 07:43:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-14 07:43:49 +0100
commitfe8b106bd60ab72e98ab836f5c702070805e197e (patch)
tree44016d57867c58de87efd4b028c171d352bbf3be /dev-python/xarray/xarray-2022.10.0.ebuild
parent30737dc88991519b90363c2c7bae8fd049098d13 (diff)
gentoo auto-resync : 14:10:2022 - 07:43:49
Diffstat (limited to 'dev-python/xarray/xarray-2022.10.0.ebuild')
-rw-r--r--dev-python/xarray/xarray-2022.10.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/xarray/xarray-2022.10.0.ebuild b/dev-python/xarray/xarray-2022.10.0.ebuild
new file mode 100644
index 000000000000..5ce78ec96b6d
--- /dev/null
+++ b/dev-python/xarray/xarray-2022.10.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="https://xarray.pydata.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.0[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+)