summaryrefslogtreecommitdiff
path: root/dev-python/xapp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-python/xapp
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-python/xapp')
-rw-r--r--dev-python/xapp/Manifest2
-rw-r--r--dev-python/xapp/xapp-2.0.2.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/xapp/Manifest b/dev-python/xapp/Manifest
index 006762cf0b94..f0c108528de7 100644
--- a/dev-python/xapp/Manifest
+++ b/dev-python/xapp/Manifest
@@ -1,3 +1,5 @@
DIST xapp-2.0.1.tar.gz 19839 BLAKE2B 692ef5a560681f415ab211b6f2870339dc80ca3ce90ac860637ce6765309b03f8ac41499ad5bcef51cde194b7cee2e3366abb3ddb5ee7e2212e3dac0da625387 SHA512 a529680ab2adbcd829ec224b7dafeb5f641afaabd51ac6cea154d1adf46772b0f2c58a78c6f136d3c6dde0b5d69a4e53a988f69d282af852ecf9ffa130ec1fe4
+DIST xapp-2.0.2.tar.gz 19946 BLAKE2B fde2f4f30fa1dbb5d4778d82bcfb347a5b8f89635df6c298d0dc509a194c528b653a1cbe4537c878bde4a8b987852ca51e37a70b6c35f96c9882c5b1b277dd36 SHA512 2b5d2a259e55384426940e6284ec9f964f4f0220b8cb364606c938ef6e1717d40ddbc3730732dddc86d460f624ac6161fe5ab55c276aedba9187a79d9d53a60e
EBUILD xapp-2.0.1.ebuild 557 BLAKE2B 65d419b08854f87e7ce577c7b5e8c51703b0fe08b9b5eecc399910ba4f49841be2249e1d3d507f1e45be38d87ede6541b4204ada4b67d386e8a428c012c0b288 SHA512 971f20be8e7942d6d718c023469a3adbc5a3d7d9303ca7eda4edff4344f66019292aabe5d5d9a4d79c1fbc90cfa8c552682373c15284832f9627de2cc1cf7980
+EBUILD xapp-2.0.2.ebuild 565 BLAKE2B c10d062f23475ba3a265dc22f7777597a0e2579b0169a9cc49d63b47d7790524ed3efad063033beee725cdca08bb458ad7ad9dffad9b291fb607e66593e85e6e SHA512 3fedafbe64e801ab06ca164f83af5b9b96864cc2f9000017395487710678f98568a8e9ed330166991c3dd1d5a4f39f5fad50a11d8e7ac2903c791cf47ded3689
MISC metadata.xml 584 BLAKE2B 7b0110a8ad67b0faa3125ddd088a8d019129d239cc541a08b4443f8bddd3c1efc1891ccbd935309fd13c940b1cf95bf6f1e769c078e895393f7bccf3a366a0ea SHA512 3273919c56af741c5cfde4b69180c20a2defdb16a59f34c0a57147f955c8454eb73cd20f5d02fe827432b7f7310e9a313b324832df96c724300cf3b05cb30141
diff --git a/dev-python/xapp/xapp-2.0.2.ebuild b/dev-python/xapp/xapp-2.0.2.ebuild
new file mode 100644
index 000000000000..602f02e2868e
--- /dev/null
+++ b/dev-python/xapp/xapp-2.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for x11-libs/xapps"
+HOMEPAGE="https://github.com/linuxmint/python3-xapp"
+SRC_URI="https://github.com/linuxmint/python3-xapp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ x11-libs/xapps[introspection]
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/python3-xapp-${PV}"