summaryrefslogtreecommitdiff
path: root/dev-python/wxpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-25 18:50:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-25 18:50:52 +0000
commite292b671b113c2cc012beddad93a3df4f9410698 (patch)
tree96b510d2f17600f87d69b1ad0edddee81cb7b791 /dev-python/wxpython
parent71d582d27eeece574ab3d904aa3fbe7742b0e895 (diff)
gentoo auto-resync : 25:03:2023 - 18:50:52
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/Manifest2
-rw-r--r--dev-python/wxpython/wxpython-4.2.0.ebuild10
2 files changed, 4 insertions, 8 deletions
diff --git a/dev-python/wxpython/Manifest b/dev-python/wxpython/Manifest
index dbcdf73ab23e..268187956b51 100644
--- a/dev-python/wxpython/Manifest
+++ b/dev-python/wxpython/Manifest
@@ -7,5 +7,5 @@ AUX wxpython-4.2.0-no-webkit.patch 1285 BLAKE2B 19fdee2293da214b8ae318b2670298b3
DIST wxPython-4.0.7.post2.tar.gz 68891167 BLAKE2B 77eb69f7a59e5be81c3d17b64c76e09a43efc9226bd87fd058483185871a95ce05dbb65614ec8b003edf52cbe1cb1a115856c0d622170c51ecacbb952106fe22 SHA512 7af89db90a0f7e6b644d61c1ede01ec36a2c295e46d44692ae9dbc4af923310c1b498a52f45b02a89e8917d844c6abe67e5f3fdd9c1d51da3312899319a349e4
DIST wxPython-4.2.0.tar.gz 70958238 BLAKE2B 2e8e34c4f5d1992983bfe4e09bb56ee5619b139b9b3b5f05dee48ecdf6971cf9fe1b0fb22aec685904eb44db6f50a4ba132a08aa91930d809040da828efa097e SHA512 9ec937a024efb2916403c84382a66004f0c2bb07471246b7de517778309ce459e929eeb59e261f538d3fa077c950628de62e49a3760fbd03ab9ff2114c6f354f
EBUILD wxpython-4.0.7-r4.ebuild 2370 BLAKE2B e8b76a2c2a0b2153c4663a4e514d0ee6c54bd5946e92dc436f854775e410031393b8f8506ae50567490b5b709eb5ada1ab3cf24c980f0a14f2d57b91e21c780c SHA512 f8e47b0de868d90b9a9fcb33c9fa22a96c8ad7d195b35917239ec840a685fdd9fc42f5a0259c644dec17886395bc433a125539ab7b09107f4f135a1b08042b95
-EBUILD wxpython-4.2.0.ebuild 3936 BLAKE2B 5cf2a44411d30e5efdf88776e151fe0105a9606030193fdab872980c292db524755ece2c98b8259c46a2886a66dc3c808dbba0dfd9c1568ac30ed0175d059aeb SHA512 702ff388df79fb4fcec21aa7aee3ca3d77f579ee97d41741b03ca12b2dcb9cc390f0361ef371388a2fd925779bc3144c64447e230bb69c4a25086edc2cc870b0
+EBUILD wxpython-4.2.0.ebuild 3838 BLAKE2B 86edaeb9e0b8029b9ff9632b997bba342ae911f502f2745b8c87a1b12b45085776ee0449793b20f3cb12134d51069341e3b4723bb3b53902955216487df3ee09 SHA512 416f15a7fa53e3ee5e6dd11a9fb7eb5a0354c53488d8127c6003bce40129e5d9652ac1c7365cf6b20311b2e3fce8b484c206025d3dddb9fedb82d5ee41ca1931
MISC metadata.xml 491 BLAKE2B ffa0cccf66f484c856fb30249bd0ccc3b0da2f3ee8e3c3a0df1782bc58e4867ff99d9711f1784b44b439f2a8bcf297c1082b49a941823f046c7f2c7977a77629 SHA512 a2f5908a276a8f9c512cb59c8d17873398c91b21977371ab724e669f3b6c032d53510fbcd183a5dc340279fc522289e617b8c313c0d825ca70d0d2a5d74f8cfa
diff --git a/dev-python/wxpython/wxpython-4.2.0.ebuild b/dev-python/wxpython/wxpython-4.2.0.ebuild
index 1c2f64bef4fe..3b580365bb1c 100644
--- a/dev-python/wxpython/wxpython-4.2.0.ebuild
+++ b/dev-python/wxpython/wxpython-4.2.0.ebuild
@@ -5,16 +5,14 @@ EAPI=8
DISTUTILS_IN_SOURCE_BUILD="1"
PYTHON_COMPAT=( python3_{9..11} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="wxPython"
WX_GTK_VER="3.2-gtk3"
-inherit distutils-r1 multiprocessing virtualx wxwidgets
-
-MY_PN="wxPython"
-MY_PV="${PV/_p/.post}"
+inherit distutils-r1 multiprocessing virtualx wxwidgets pypi
DESCRIPTION="A blending of the wxWindows C++ class library with Python"
HOMEPAGE="https://www.wxpython.org/"
-SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_PN}-${MY_PV}.tar.gz"
LICENSE="wxWinLL-3"
SLOT="4.0"
@@ -48,8 +46,6 @@ BDEPEND="
)
"
-S="${WORKDIR}/${MY_PN}-${MY_PV}"
-
PATCHES=(
#"${FILESDIR}/${PN}-4.0.6-skip-broken-tests.patch"
"${FILESDIR}/${PN}-4.2.0-no-attrdict.patch"