summaryrefslogtreecommitdiff
path: root/dev-python/wsproto/wsproto-0.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/wsproto/wsproto-0.15.0.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/wsproto/wsproto-0.15.0.ebuild')
-rw-r--r--dev-python/wsproto/wsproto-0.15.0.ebuild20
1 files changed, 6 insertions, 14 deletions
diff --git a/dev-python/wsproto/wsproto-0.15.0.ebuild b/dev-python/wsproto/wsproto-0.15.0.ebuild
index e6b15a59a3ea..b4e0f094aaf7 100644
--- a/dev-python/wsproto/wsproto-0.15.0.ebuild
+++ b/dev-python/wsproto/wsproto-0.15.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -14,20 +14,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
- =dev-python/h11-0.8*[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dataclasses[${PYTHON_USEDEP}]
+ ' python3_6)
"
-python_test() {
- py.test -v || die "Testing failed"
-}
+distutils_enable_tests pytest