summaryrefslogtreecommitdiff
path: root/dev-python/wsgiproxy2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/wsgiproxy2
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/wsgiproxy2')
-rw-r--r--dev-python/wsgiproxy2/Manifest2
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.4.6-r1.ebuild9
2 files changed, 4 insertions, 7 deletions
diff --git a/dev-python/wsgiproxy2/Manifest b/dev-python/wsgiproxy2/Manifest
index b973456a123e..aa7cf82696cd 100644
--- a/dev-python/wsgiproxy2/Manifest
+++ b/dev-python/wsgiproxy2/Manifest
@@ -1,4 +1,4 @@
AUX wsgiproxy2-0.4.6-tests.patch 736 BLAKE2B 4680b256f190d1bde89b5e8735cdd03a68061a4c68162033da329068838ea262f231a07aa6a944f9a9889c415af0c65eb3c885d9b69d9ee3fa8878003e886545 SHA512 960b5be5e67cc77d86c37ea5f6966ca838455cea74d79288e245acb47c9b374a285a3135c39330b2e8928760fd244e8addad8e4f707b7cbee1dc4801562a50f5
DIST WSGIProxy2-0.4.6.tar.gz 16481 BLAKE2B c33dc34d430da795e8144e06e1d6f100cce7d0155295c2d3038567a048647a4f008dbc0156fd4234ce069b3f4ec01af0e42b174dd68c92c9cb3ff4e13be83f8a SHA512 c60d794c0c8b383bf1857ec325d6d0b4fce9c4aec4a06cbf9d7549b609633e491e137342b7bbaf4eec12462eabba63096328c8517b0685e241d1baecd5827cad
-EBUILD wsgiproxy2-0.4.6-r1.ebuild 1096 BLAKE2B d0823176dec75a1b6e18bedb6c2028c47f9a56e637b44193ac6debd479a0ac2975c5ef4a92f91c8a8bd732ec5aadc9409e747b4da18fd5d54376ff595c88f1a2 SHA512 57c1e87c525a115e98f5be1fce2dfb16d80e49ab303019aa96156e2f6b99a21220c09fdbc49a40958a6dabd349a967104c843e41eeed0920982512f613050a9e
+EBUILD wsgiproxy2-0.4.6-r1.ebuild 1043 BLAKE2B cef79f4a9d625a58c56e698eb57ad16d8545f5bf19f3e0d073b24f21d1153d411fc8e65397f911909cbe9b0bff868f037f41818c19444826899f791fbb4da848 SHA512 d6f6cf33f38a9640952d33287bfa5773ac529740debcae42c029f74ab15048d443aa09b6e87a539c3e9a1f5a20230491ff219a8187ba1ac298321971ff5ff63a
MISC metadata.xml 337 BLAKE2B b34d470df573b61875a4d4bbff338d30a9bb21fc1905a73e47639fd9f3a9c3222b8d5dd54daeb37228dea119cdd354d618cd544de3ab7b46b826f70faaa9add0 SHA512 85c5219804c984dd8f028fcafd94476d0e44a09154d852fcc86194f6c1fb4dbe47228346be487aad7de0588079499c8e47cca0166721f519a8a99cb359fd4f03
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.4.6-r1.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.4.6-r1.ebuild
index fcabead12956..19cda237b3c2 100644
--- a/dev-python/wsgiproxy2/wsgiproxy2-0.4.6-r1.ebuild
+++ b/dev-python/wsgiproxy2/wsgiproxy2-0.4.6-r1.ebuild
@@ -3,15 +3,15 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
MY_PN="WSGIProxy2"
-
DESCRIPTION="HTTP proxying tools for WSGI apps"
HOMEPAGE="https://pypi.org/project/WSGIProxy2/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="MIT"
SLOT="0"
@@ -23,16 +23,13 @@ RDEPEND="
dev-python/urllib3[${PYTHON_USEDEP}]
dev-python/webob[${PYTHON_USEDEP}]
"
-BDEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
>=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
dev-python/socketpool[${PYTHON_USEDEP}]
)"
# Testing also revealed the suite needs latest webtest
-S="${WORKDIR}/${MY_PN}-${PV}"
-
PATCHES=(
"${FILESDIR}/wsgiproxy2-0.4.6-tests.patch"
)