summaryrefslogtreecommitdiff
path: root/dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild')
-rw-r--r--dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild b/dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild
new file mode 100644
index 000000000000..4e82dd4d563f
--- /dev/null
+++ b/dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+COMMIT="0fbd074c257c51b73de05b25ccb6488801320a32"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Accelerator for ws4py, autobahn and tornado"
+HOMEPAGE="https://pypi.org/project/wsaccel/ https://github.com/methane/wsaccel"
+SRC_URI="https://github.com/methane/wsaccel/archive/${COMMIT}.zip -> ${P}.zip"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+python_test() {
+ py.test -v || die
+}