summaryrefslogtreecommitdiff
path: root/dev-python/ws4py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/ws4py
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/ws4py')
-rw-r--r--dev-python/ws4py/Manifest4
-rw-r--r--dev-python/ws4py/ws4py-0.5.1-r1.ebuild12
-rw-r--r--dev-python/ws4py/ws4py-9999.ebuild12
3 files changed, 18 insertions, 10 deletions
diff --git a/dev-python/ws4py/Manifest b/dev-python/ws4py/Manifest
index 4b6c77899dfa..b073f4d6b248 100644
--- a/dev-python/ws4py/Manifest
+++ b/dev-python/ws4py/Manifest
@@ -1,5 +1,5 @@
AUX ws4py-0.5.1-python3.7+-compatibility.patch 3713 BLAKE2B f5c811b6dce12637307d2a845daa0e9e932452ba34416b088531734013f1617901617d82804b32ec22026d50c27152b68fb548b0871a11ac20ffa21fc5b435b0 SHA512 3012d74e348f7965fee811c9b0e290dcefcc4f365159ecc0fc5bc9dc77ff0e5e6d1448b62b0ced1f9e87dc2bf29f9a831d110301257d260dcb3f2d1ee7ed4f80
DIST ws4py-0.5.1.tar.gz 116673 BLAKE2B 31db304800f0d3da61dc4c1a3381a8fcfcfa8f16b36d916311cc32f1d294c9f7b3627dac673edf824f529f485f825ca418ab1e1a8a2fda5583c6a6a1bd9b752c SHA512 4c90d66d37fb5bdc8f7fc9fd184b20a7dc2dae811ecf3a041477e3c26a2577008be7041799daca5b8c0de65cb2454022a6c135cf02534ca98b6946abbfce0e11
-EBUILD ws4py-0.5.1-r1.ebuild 1780 BLAKE2B 6e228f3dff0ca52c6027a115dd4cd89ac28edcf759cb14a4ebc3cfb26a550f025fd76c3449d627097ceaec34952cbc1dbecb0f4867b4aa9707211ce9ec5f04c8 SHA512 f38cb30a61459f796e17002d17bc5ac648daf0c45ee557eae637ac449e63da18f654d43f331feefacbf1c4ac25e7de52771908128765bb33620d1c1792865efb
-EBUILD ws4py-9999.ebuild 1782 BLAKE2B 80cf70fe7dee9b0b57a8b88877c37ce4f608cae500d06a41bbd3365a1560d970821bd798e5de1a98e11a74dd212254bbc68785b190a68c9153ef41ffb2d214e3 SHA512 756ffdb8c660aebc18f487453f1fd73b7034d80d7b65c9e45b9d774c161adc3b28cac6cc82d35f8c5f1de395574bb26a8aa60d8d149b39bd82c6c09d9ae12c13
+EBUILD ws4py-0.5.1-r1.ebuild 1786 BLAKE2B ea8be6aede0a3602fcfd41f066f06bd87f50bdc39016e4d378d5f77c5027c653c024cbed16a14a4404d7649f938bd90a9b6844cbc63e82231917cc4c80722c50 SHA512 ecdb19ee5104d10ef32d0101ca17e1206389ad935acfb3f9efab322fa2aa12c81e6e38a1010975994377118c49c227215ee74ea4d8d5b64a44ee4838bcad47ef
+EBUILD ws4py-9999.ebuild 1788 BLAKE2B 8f28b558ffa7494b52dbe6676b02bad4fdf4a064d47f1be19d4659d36f565f148f79118342f003ba51d94b3ece32ba4936c60ad27989593ea46439132b05bc6a SHA512 ff8c9974aab71564e8b20847d36ff795d8bc7456b4011146677124df23575fd327bdaa2c7534af65614c7fd475446300c4161fd56db74f11d27931f9d154530c
MISC metadata.xml 507 BLAKE2B e068388bd7979e65aa1319f5f528003dc2d2e20f686d9f7fdc6b48d98b115ca156ac05866fc5004649edcc64448e5a24f4b05818fa803827fd0ee3d053eb1da4 SHA512 658be5099572b43e2a0f23cfcb05f3b1e7b9e3e42e7686759b956ef0ea5407d5f4af72995ba4360d4df097099cd3058b5f9783be27ebf953098a3bcd5cc66a89
diff --git a/dev-python/ws4py/ws4py-0.5.1-r1.ebuild b/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
index 66d94c727f00..94d185d86706 100644
--- a/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
+++ b/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# We could depend on dev-python/cherrypy when USE=server, but
@@ -7,12 +7,14 @@
# pypy is viable but better with a cutdown set of deps
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+
+PYTHON_COMPAT=( python3_{7,8,9} )
PYTHON_REQ_USE="threads(+)?"
MY_PN="WebSocket-for-Python"
inherit distutils-r1
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/Lawouach/${MY_PN}.git"
inherit git-r3
@@ -42,11 +44,13 @@ DEPEND="test? (
>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
)"
-PATCHES=( "${FILESDIR}"/${PN}-0.5.1-python3.7+-compatibility.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.1-python3.7+-compatibility.patch
+)
python_test() {
# testsuite displays an issue with mock under py3 but is non fatal
- "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
+ "${EPYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
}
python_install() {
diff --git a/dev-python/ws4py/ws4py-9999.ebuild b/dev-python/ws4py/ws4py-9999.ebuild
index 3561e1388c9c..5d471f0ff142 100644
--- a/dev-python/ws4py/ws4py-9999.ebuild
+++ b/dev-python/ws4py/ws4py-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# We could depend on dev-python/cherrypy when USE=server, but
@@ -7,12 +7,14 @@
# pypy is viable but better with a cutdown set of deps
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+
+PYTHON_COMPAT=( python3_{7,8,9} )
PYTHON_REQ_USE="threads(+)?"
MY_PN="WebSocket-for-Python"
inherit distutils-r1
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/Lawouach/${MY_PN}.git"
inherit git-r3
@@ -42,11 +44,13 @@ DEPEND="test? (
>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
)"
-PATCHES=( "${FILESDIR}"/${PN}-0.5.1-python3.7+-compatibility.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.1-python3.7+-compatibility.patch
+)
python_test() {
# testsuite displays an issue with mock under py3 but is non fatal
- "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
+ "${EPYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
}
python_install() {