summaryrefslogtreecommitdiff
path: root/dev-python/wrapt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 10:00:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 10:00:13 +0000
commit73ef00f9e2b100c7d0fedede11300940cc26670a (patch)
tree19d1f10cdd98aec4743c36942242eac9f318641d /dev-python/wrapt
parent063e5b486db858a2b1ecec798af89f5484d475bd (diff)
gentoo auto-resync : 27:02:2023 - 10:00:13
Diffstat (limited to 'dev-python/wrapt')
-rw-r--r--dev-python/wrapt/Manifest2
-rw-r--r--dev-python/wrapt/wrapt-1.15.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/wrapt/Manifest b/dev-python/wrapt/Manifest
index 4159ecca7d17..6b1827795158 100644
--- a/dev-python/wrapt/Manifest
+++ b/dev-python/wrapt/Manifest
@@ -1,3 +1,5 @@
DIST wrapt-1.14.1.gh.tar.gz 133767 BLAKE2B 407a9531f581b034be7fe4392dcbf94803aa9c3a82d7c392750dfef62a5cbb84582e292819bf749356fad2b6e98cc89777df0f3b0f4ca70422e75b72ad256711 SHA512 c67e99eb29afeefb2512fb545cd180b8e96f69235d6281edebe62ea5e411188a904a7e683afdda2d6a86cf8b7fd74f79a3c3bec04e19a7c5ef347729bb43f94c
+DIST wrapt-1.15.0.gh.tar.gz 137402 BLAKE2B 8c4764251a89f7795fef71dd71d9c36611d896d2e2791a5e7ce4f665f7b477e683f21aa05251a6ceb96644221a7ff9b01dfe98a7f4d278987dedc17ead39b343 SHA512 6be3fc6380e6bb11a26e35fb093ca54d2e851ab384682f6b1201599980c0429c1e2f23089540b66dd80985baaaf3fb93ce29034758e062e2cfb2f52e3b362779
EBUILD wrapt-1.14.1.ebuild 793 BLAKE2B c58f6d1970cd527dd32d594e188fdc344ce7329c1948ee816e1798ef45407b72cc0c86c66b1201b4a9783be6e97da4a380f4d6f48ff6c40cad79daeead239b11 SHA512 908d17dc9bbb12bbc50241a03d282cddb2d2e5db893ac929cbbd6ad38851fb30f179746c3f8e48be9977d218088b296593fdd1cc248f4114bd36e311a53eb67b
+EBUILD wrapt-1.15.0.ebuild 872 BLAKE2B bec55b13ce4ff253196032151f431d85b3eeac91262ace1dacd5c8b452e86966950ca3b5e1b2be6aedab6d70420ae7261a191019db3d615f82ee288561d6df89 SHA512 586217a4f41c765731ec6a3359bfe4926021e3218d277a59b63d6b330fa02dc7a48c0bb91f8f7a6395080ff595714cc3a8aa1b4d2afedd232b50a597900633a5
MISC metadata.xml 370 BLAKE2B 251d8c90cd2a0a1b9fbc714b624c7113e9791f268130211160655f4e4e32aadaddaf98a95bb6d9fff5a5df128da9d551b1281a28e4bd7fa6e3c9db7d35b10829 SHA512 31b369317f4a44d593d9fb72bcb9fcb792809323862866da7c3464ca2282e29a65cd353909c05782b85b162cff363b0ad8ea4750d89c942d442034b9a6eb7dba
diff --git a/dev-python/wrapt/wrapt-1.15.0.ebuild b/dev-python/wrapt/wrapt-1.15.0.ebuild
new file mode 100644
index 000000000000..1b7cfe7b88b0
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.15.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="
+ https://github.com/GrahamDumpleton/wrapt/
+ https://pypi.org/project/wrapt/
+"
+SRC_URI="
+ https://github.com/GrahamDumpleton/wrapt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_compile() {
+ local -x WRAPT_INSTALL_EXTENSIONS=true
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}