summaryrefslogtreecommitdiff
path: root/dev-python/wrapt/wrapt-1.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-05 10:11:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-05 10:11:29 +0000
commit68883bef20f77c2d72dfdf20bf5f9d4a5ea5ad9c (patch)
tree5bea0b1c5edcc839425e169609eb2bb2fc6aa760 /dev-python/wrapt/wrapt-1.15.0.ebuild
parentd0f8b473674427ef4f618c94d4d132a7f79578e3 (diff)
gentoo auto-resync : 05:11:2023 - 10:11:29
Diffstat (limited to 'dev-python/wrapt/wrapt-1.15.0.ebuild')
-rw-r--r--dev-python/wrapt/wrapt-1.15.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/wrapt/wrapt-1.15.0.ebuild b/dev-python/wrapt/wrapt-1.15.0.ebuild
index 9e33fe5a5171..0983b6eac0c3 100644
--- a/dev-python/wrapt/wrapt-1.15.0.ebuild
+++ b/dev-python/wrapt/wrapt-1.15.0.ebuild
@@ -22,12 +22,20 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+native-extensions"
distutils_enable_tests pytest
distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+src_prepare() {
+ # pypy3.9+ change, upstream commented this out
+ # in 59680c8bb998defa3be522fef6e49fd276bebe58
+ sed -i -e 's:if is_pypy:if False:' tests/test_object_proxy.py || die
+ distutils-r1_src_prepare
+}
+
python_compile() {
- local -x WRAPT_INSTALL_EXTENSIONS=true
+ local -x WRAPT_INSTALL_EXTENSIONS=$(usex native-extensions true false)
distutils-r1_python_compile
}