summaryrefslogtreecommitdiff
path: root/dev-python/whoosh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/whoosh
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/whoosh')
-rw-r--r--dev-python/whoosh/Manifest2
-rw-r--r--dev-python/whoosh/whoosh-2.7.4.ebuild36
2 files changed, 10 insertions, 28 deletions
diff --git a/dev-python/whoosh/Manifest b/dev-python/whoosh/Manifest
index 0584ca753de4..deecb65bf007 100644
--- a/dev-python/whoosh/Manifest
+++ b/dev-python/whoosh/Manifest
@@ -1,4 +1,4 @@
AUX whoosh-2.7.4-tests-specify-utf8.patch 319 BLAKE2B b889ccda8723208af56659616ead64b1779c1bd96abff594a099ddeaa9aac3be86603dd0825507b30a900f38d80b184dfdbddfa42087969ec7fbce43cc8c1617 SHA512 53dc8336ac9895659d92001cb22137011d9da753c299bc3fecd34ed6b42f0f169967dfd41b0403462e54e62af1f6390c58386a91a89ddc880a4fe0a4e05ce14b
DIST Whoosh-2.7.4.tar.gz 968741 BLAKE2B 698ec603eb1201f2b1a934785f84108cb5d91114c9a4e1943cfcd2c8c878f7fb0a0868d54d3a11f8aa30890179c555bdc11cbf34962f5f4781c6d43a090ba872 SHA512 7cdefdcf52b704ffe50c00718c42677e2ddfe879f81ad2d14b580b0e026cc0ebb6b9ddc99d8709eaff4eb9b83f654b042c8792821e1ed90aa85cfa6f82845074
-EBUILD whoosh-2.7.4.ebuild 1488 BLAKE2B 423fdf210313e27b3052c11422b302b539cb4b3024caf8ea5a2e4ab3fd033cc7f3b0a8fccd85dff6ab36e385284048a0b5692efef86dd694dfd0969fc7a955c3 SHA512 1ed8dc851fa6bc6a5fc1ffe66e1f4bda3e8ea1b52eb324614320b9f6bde84ecff5ec763847089811aae850ab1304e104d4a78670c1437340c236a7d3a6e99e50
+EBUILD whoosh-2.7.4.ebuild 988 BLAKE2B cb9dc11a0fbbac0b6964ddcab46359a9123a1d76be6a63cd467b5eef57cf3d55ffffdf09af013ec6de8d12a322ab9ae1d2e0e8a686a1e9f21b983431527f4ce1 SHA512 487a47cd68d2fdf892ba22ef21f46dddf05601bdcc2c40123956523b8fa5c241ed2d3d4d87d8121d6cca25c66eaf932af6e3f139d6232472a03fa53c97c20516
MISC metadata.xml 817 BLAKE2B dfecf5c1485e029a3614d0a45b78ae77fa7965000e5e9b95d6e7ed21155c4781f23b895f24b7189b1d7fbe7007828dd152d30c4013ea35d93ea1c5dcc985b834 SHA512 b9c1def2c09a31740729aed91c02a3382c9b8f10d9f959c0c80f41ac4822ac5ad3b2c7c998e244f91e64581c17c4d52a7264f679b44a9981587c053bc3b576ed
diff --git a/dev-python/whoosh/whoosh-2.7.4.ebuild b/dev-python/whoosh/whoosh-2.7.4.ebuild
index b64c25fbd2ea..3ca02d1cda5a 100644
--- a/dev-python/whoosh/whoosh-2.7.4.ebuild
+++ b/dev-python/whoosh/whoosh-2.7.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
@@ -10,44 +10,26 @@ inherit distutils-r1
DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
HOMEPAGE="https://bitbucket.org/mchaput/whoosh/wiki/Home/ https://pypi.org/project/Whoosh/"
SRC_URI="mirror://pypi/W/${PN^}/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~x64-solaris"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${P^}"
PATCHES=(
"${FILESDIR}"/${PN}-2.7.4-tests-specify-utf8.patch
)
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
python_prepare_all() {
# (backport from upstream)
sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
-
- # Prevent un-needed download during build
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ # fix old section name
+ sed -i -e 's@\[pytest\]@[tool:pytest]@' setup.cfg || die
+ # TODO: broken?
+ sed -i -e 's:test_minimize_dfa:_&:' tests/test_automata.py || die
distutils-r1_python_prepare_all
}
-
-python_compile_all() {
- # https://bitbucket.org/mchaput/whoosh/issue/403/
- if use doc; then
- sphinx-build -b html -c docs/source/ docs/source/ docs/source/build/html || die
- HTML_DOCS=( docs/source/build/html/. )
- fi
-}
-
-python_test() {
- # https://bitbucket.org/mchaput/whoosh/issue/412/tarball-of-whoosh-270-pypi-missing-english
- # tarball missing a file english-words.10.gz which when added sees all tests pass.
- esetup.py test
-}