summaryrefslogtreecommitdiff
path: root/dev-python/whichcraft/whichcraft-0.6.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/whichcraft/whichcraft-0.6.1-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/whichcraft/whichcraft-0.6.1-r1.ebuild')
-rw-r--r--dev-python/whichcraft/whichcraft-0.6.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/whichcraft/whichcraft-0.6.1-r1.ebuild b/dev-python/whichcraft/whichcraft-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..6a4e14d9828f
--- /dev/null
+++ b/dev-python/whichcraft/whichcraft-0.6.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cross-platform cross-python shutil.which functionality"
+HOMEPAGE="https://github.com/cookiecutter/whichcraft"
+SRC_URI="https://github.com/cookiecutter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.rst HISTORY.rst CONTRIBUTING.rst )
+
+distutils_enable_tests pytest