summaryrefslogtreecommitdiff
path: root/dev-python/whelk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/whelk
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/whelk')
-rw-r--r--dev-python/whelk/Manifest3
-rw-r--r--dev-python/whelk/metadata.xml19
-rw-r--r--dev-python/whelk/whelk-2.7.1.ebuild21
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/whelk/Manifest b/dev-python/whelk/Manifest
new file mode 100644
index 000000000000..85b394f46832
--- /dev/null
+++ b/dev-python/whelk/Manifest
@@ -0,0 +1,3 @@
+DIST whelk-2.7.1.tar.gz 69983 SHA256 991ccf6f1b883d0e66305e242bc5d024518b5936fa60cce077f901b9ec13dc77 SHA512 39b73ed09a0d2442cdde5b8bae72805571a172c6acfa3f652c8cb125d3a400f2538fe6534179f95383d321e8975b6127115616372c60c736e8cd8ceba00ef093 WHIRLPOOL c5e571a154c9323e4c5316923efcf9a4394d8a4689e00eff2bb28b2eb3366c05b4a9b65600e014beb2a167cc217fe8e2494f5e07c4126d05af2b991d32ee31a2
+EBUILD whelk-2.7.1.ebuild 464 SHA256 5858a06f754b06cd23b56195a597022fa3a8cf7e398dce9ca8ec30859e761735 SHA512 26533a949fd765ea0643cd7ff26f6b18fe2b351d493784e49006d9207ae77fb8c0aaa105a44d7f7810631c544a6d2d01b3cfd84128dba4df5b057bc58947a0dc WHIRLPOOL dd379c3f7e8c6e1e7603a337d0bf56701366823a36de3e54fb6e5654e15aaf98bbb677c6e46d3b62d0a11c6b0904a24c1a1710522d79265e362704a99de09775
+MISC metadata.xml 666 SHA256 387204889d3e496ed4b626f28e25b505835904158965320100f0e32c8648cbf4 SHA512 92f0a2758700c57debe1c5190c970c1b8279262af9809490368fe2e3c1c6d4a5960ac17633fef4aa5c3786bd4ff2dc42564b7d55102e81096f3f9e602cff4822 WHIRLPOOL a7556feb40d8164f3428f5f5c9f105736d4143d8066c26ecf85939e125957d925a2c41cfdd6d8e261e7003af6df90ecb31b8743d013ca24bfa21539f0bb1b924
diff --git a/dev-python/whelk/metadata.xml b/dev-python/whelk/metadata.xml
new file mode 100644
index 000000000000..2bdfb4a473d9
--- /dev/null
+++ b/dev-python/whelk/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>nicolasbock@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ We all like python for scripting, because it's so much more powerful
+ than a shell. But sometimes we really need to call a shell command
+ because it's so much easier than writing yet another library in python
+ or adding a dependency.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">seveas/whelk</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/whelk/whelk-2.7.1.ebuild b/dev-python/whelk/whelk-2.7.1.ebuild
new file mode 100644
index 000000000000..62139f41888c
--- /dev/null
+++ b/dev-python/whelk/whelk-2.7.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pretending python is a shell"
+HOMEPAGE="https://pypi.python.org/pypi/whelk"
+SRC_URI="https://github.com/seveas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_test() {
+ ${EPYTHON} -m unittest discover || die
+}