summaryrefslogtreecommitdiff
path: root/dev-python/webtest/webtest-3.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 21:18:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 21:18:33 +0100
commit63a4617476a3b084928b38d816b9ed6e196d62f5 (patch)
treef1c7e30e8c9b33d9f7e7b0a2e3dbd1d1121358c4 /dev-python/webtest/webtest-3.0.0-r1.ebuild
parent662f71ae67cd775d7fbb79b5091676c0e07a992b (diff)
gentoo auto-resync : 29:05:2023 - 21:18:33
Diffstat (limited to 'dev-python/webtest/webtest-3.0.0-r1.ebuild')
-rw-r--r--dev-python/webtest/webtest-3.0.0-r1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/webtest/webtest-3.0.0-r1.ebuild b/dev-python/webtest/webtest-3.0.0-r1.ebuild
index 8e4a5a67c8eb..55be134cdd50 100644
--- a/dev-python/webtest/webtest-3.0.0-r1.ebuild
+++ b/dev-python/webtest/webtest-3.0.0-r1.ebuild
@@ -6,7 +6,8 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN="WebTest"
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+# py3.12 should pass but pyquery doesn't yet support 3.12
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
inherit distutils-r1 pypi
@@ -37,6 +38,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/webtest-2.0.33-no-pylons-theme.patch"
+ "${FILESDIR}/webtest-3.0.0-python3.12-unittest.patch"
)
distutils_enable_sphinx docs