summaryrefslogtreecommitdiff
path: root/dev-python/websockets/websockets-10.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 20:57:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 20:57:17 +0000
commit9bc9c4dcc38dc560cff8e5d083d1e5f282ddde98 (patch)
treeaebfd3698cdc5ed079dbfd553063a19b4662965d /dev-python/websockets/websockets-10.3.ebuild
parentcc2c9e975285d6fb1be1b71d18ba4cca7991b921 (diff)
gentoo auto-resync : 02:12:2022 - 20:57:16
Diffstat (limited to 'dev-python/websockets/websockets-10.3.ebuild')
-rw-r--r--dev-python/websockets/websockets-10.3.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/websockets/websockets-10.3.ebuild b/dev-python/websockets/websockets-10.3.ebuild
deleted file mode 100644
index d71d754cb413..000000000000
--- a/dev-python/websockets/websockets-10.3.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for building WebSocket servers and clients in Python"
-HOMEPAGE="
- https://websockets.readthedocs.io/
- https://github.com/aaugustin/websockets/
- https://pypi.org/project/websockets/
-"
-SRC_URI="
- https://github.com/aaugustin/websockets/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}/${P}-py311.patch"
-)
-
-python_test() {
- local EPYTEST_DESELECT=(
- # very fragile to speed
- tests/legacy/test_protocol.py::ServerTests::test_local_close_receive_close_frame_timeout
- )
-
- epytest tests
-}