summaryrefslogtreecommitdiff
path: root/dev-python/websockets/websockets-10.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/websockets/websockets-10.3.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/websockets/websockets-10.3.ebuild')
-rw-r--r--dev-python/websockets/websockets-10.3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/websockets/websockets-10.3.ebuild b/dev-python/websockets/websockets-10.3.ebuild
index 8ae85335baa3..d71d754cb413 100644
--- a/dev-python/websockets/websockets-10.3.ebuild
+++ b/dev-python/websockets/websockets-10.3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
@@ -21,10 +21,14 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}/${P}-py311.patch"
+)
+
python_test() {
local EPYTEST_DESELECT=(
# very fragile to speed