summaryrefslogtreecommitdiff
path: root/dev-python/webencodings/webencodings-0.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/webencodings/webencodings-0.5.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/webencodings/webencodings-0.5.1.ebuild')
-rw-r--r--dev-python/webencodings/webencodings-0.5.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/webencodings/webencodings-0.5.1.ebuild b/dev-python/webencodings/webencodings-0.5.1.ebuild
new file mode 100644
index 000000000000..b40082e8ad6e
--- /dev/null
+++ b/dev-python/webencodings/webencodings-0.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Character encoding aliases for legacy web content"
+HOMEPAGE="https://github.com/SimonSapin/python-webencodings http://pypi.python.org/pypi/webencodings"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all(){
+ cat >> setup.cfg <<- EOF
+ [pytest]
+ python_files=test*.py
+ EOF
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v -v || die
+}