summaryrefslogtreecommitdiff
path: root/dev-python/weasyprint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/weasyprint
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest2
-rw-r--r--dev-python/weasyprint/weasyprint-56.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index ac8a685400ed..828f2ccb90bb 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,3 +1,5 @@
DIST weasyprint-55.0.tar.gz 410970 BLAKE2B ba77f249c3568031eff9b7110864b69113f71ea197d0c7136de01bd40155a437b5e540e87219e6ca49428b98d8ec471dcf9ed1d0224d68a3b320e5fffb568239 SHA512 96cc6de5af86da47aa0b5a84c3f00679690774574f3370ca319afe77f3eb9c9725f3b0a6cbddf589f23f444972bc77b07cce7e27ee2c466484636b3cb30250a3
+DIST weasyprint-56.0.tar.gz 419236 BLAKE2B c64d382e4ac169904a51fec17152faacccf4ccdab775a3b34b0db7e0a4306e6cadf6810482cee5535991400455864749cce1fc6ba5e0b469a3eb934d62298028 SHA512 d8efc83f77967a514d26806a9b73ef03e047431c6db9b367cd23a819b4a68714d216081afc74162b60084d0f3755498dc782d0335069bc9e70c42b611b737eec
EBUILD weasyprint-55.0.ebuild 1069 BLAKE2B 990b3ea546068fbbe204bc328df21f9a63d8ffe031cf692bbf8aea6a6c21ba42f42933e96351a6ed27c0e71288668639854926b2007e889a3bd08321880c3bab SHA512 5df31ae924d16f392e372bca733ebc5b5089960e11d161a192d6a69c18a1f01d6ca9c7b810725cf22dae7817617d3d4229ea399fb1280f200df02b352c1d24e7
+EBUILD weasyprint-56.0.ebuild 1067 BLAKE2B 49f990e2106b3a06d9284d82dd08c7a1050c0779b9f7a462bb8cbd1af0b1d5b501c9c6f859f3b38e033b7bc4e1270342ffc64a0fae2a399b79b126b8e4b7b984 SHA512 4a450739ba48f50351674425688ab27476252fb467e61a67429b19ca35900c6ee08d795af2526965b280d10fab04156fb5799ed9c41a075e61fe3644bd57dce0
MISC metadata.xml 382 BLAKE2B 3e5d142b055354e1ea440d9efd4bf92458b1da3f777dd90929ce2041ca6e0969fa6e58aacfb4a5a93ff90805e0d8ec4c9c6253559ca54698f5029639ce35ac8a SHA512 43415064a6f56eaca974031e51d63118d1c65b33e4399302fc72cc2cd6f15e0a47cf411b18d3c5136e866115855deb19b6a9e058a18049151959ce5ee29ececf
diff --git a/dev-python/weasyprint/weasyprint-56.0.ebuild b/dev-python/weasyprint/weasyprint-56.0.ebuild
new file mode 100644
index 000000000000..dd405c38ee37
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-56.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="https://weasyprint.org https://github.com/Kozea/WeasyPrint"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ <app-text/ghostscript-gpl-9.56
+ media-fonts/ahem
+ media-fonts/dejavu
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}