summaryrefslogtreecommitdiff
path: root/dev-python/wcwidth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/wcwidth
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/wcwidth')
-rw-r--r--dev-python/wcwidth/Manifest4
-rw-r--r--dev-python/wcwidth/metadata.xml12
-rw-r--r--dev-python/wcwidth/wcwidth-0.1.7-r1.ebuild27
-rw-r--r--dev-python/wcwidth/wcwidth-0.1.7.ebuild27
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/wcwidth/Manifest b/dev-python/wcwidth/Manifest
new file mode 100644
index 000000000000..078cd74c9137
--- /dev/null
+++ b/dev-python/wcwidth/Manifest
@@ -0,0 +1,4 @@
+DIST wcwidth-0.1.7.tar.gz 22884 BLAKE2B 6d51be31c6cf11a23de48bfecd00d8b95e15c80b83559f67689611ac0d8406c18e3a761dc57a868e8c991ee07e286aed66fe77d905483f63ee998ca431fd35f2 SHA512 5bc9625fbd10721a50a3ac7d7f91012cca8e4f83533f265cf56890498bc52a53b155c82e67d6bc5523a5593c8d7992a1dec2a0f590318170eddf987c56f9c368
+EBUILD wcwidth-0.1.7-r1.ebuild 683 BLAKE2B cac4d8f1c4046ff724fe464e8b03c781c0da044fe521d48c4c9efae8cf13bd27ec0d5698add345d54c36fabab9e3db6cca73c884637f7ec497e7876d01ca98fc SHA512 b77b2133a3d132ad18705251c325538cd9b278c270e718123d856f408af1300af67d235e247a23a86badf35c3dd0aedc013cf4a1ef18e7a9ae6c4bf260df95c7
+EBUILD wcwidth-0.1.7.ebuild 658 BLAKE2B 961127ddf24313a87dc0a71ffcba5afec059b2b2e1971775daeb71a2aa18dcfc72a19b370ed0a4c816e87f70f1f4617f7e73c38d838e3a0cd10e435e8fb21a75 SHA512 b868e87270ed8df5ff8fc8ec4a8e12fe8ecead63240c38139283bee661eff5eb1f9dc705ee6211b84c9b8683bba95794efd6a9f7091f87f886ccb4a2d712f5e0
+MISC metadata.xml 376 BLAKE2B 94917ec41c518ca9b328d9be7afbcba198376b1c28c3f24e24e3e994aecd877db745b07377bbba0a1c7d7b00e21cd53de31ca9ee4a0f08696d11b922cdc98771 SHA512 9f797fb27ebf7f1fd99d2c9a8c61ccffe1cc40f46991d9437dae121366da1edb31ee6ada3c202ced30fde0a90766453e72bcbb43a48919519f3de0b31681e213
diff --git a/dev-python/wcwidth/metadata.xml b/dev-python/wcwidth/metadata.xml
new file mode 100644
index 000000000000..6f588e5a84a1
--- /dev/null
+++ b/dev-python/wcwidth/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">wcwidth</remote-id>
+ <remote-id type="github">jquast/wcwidth</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wcwidth/wcwidth-0.1.7-r1.ebuild b/dev-python/wcwidth/wcwidth-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..ca6f6b62186f
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.1.7-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="https://pypi.org/project/wcwidth/ https://github.com/jquast/wcwidth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v -rs --strict wcwidth/tests || die
+}
diff --git a/dev-python/wcwidth/wcwidth-0.1.7.ebuild b/dev-python/wcwidth/wcwidth-0.1.7.ebuild
new file mode 100644
index 000000000000..6bf84f0c1be7
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.1.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="https://pypi.org/project/wcwidth/ https://github.com/jquast/wcwidth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v -rs --strict wcwidth/tests || die
+}