summaryrefslogtreecommitdiff
path: root/dev-python/wcwidth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-06 12:54:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-06 12:54:39 +0000
commit56330f065f2b903d9e1b2dffc63719fef5897a45 (patch)
tree659a7ebca7cb9f7504b018c1484df84ba4f9ab01 /dev-python/wcwidth
parent1774f0a748546cbd792bf1eb44757b63be2e0114 (diff)
gentoo auto-resync : 06:01:2024 - 12:54:38
Diffstat (limited to 'dev-python/wcwidth')
-rw-r--r--dev-python/wcwidth/Manifest2
-rw-r--r--dev-python/wcwidth/wcwidth-0.2.13.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/wcwidth/Manifest b/dev-python/wcwidth/Manifest
index 9b6776312e64..fc8c07d48d1b 100644
--- a/dev-python/wcwidth/Manifest
+++ b/dev-python/wcwidth/Manifest
@@ -1,3 +1,5 @@
DIST wcwidth-0.2.12.tar.gz 99898 BLAKE2B 3bfec1c2ab34103bf0706fcd0385dd034e2381f47b355a71c1167647c5fc168fa1b84737d0aae04412dceedc8417b6982455a826d1114f6f948e8755a9727838 SHA512 3d8d9d2c750f2e97db42135dc1322fc432ce25edc8e692b263e5b80c96779398e8b8eecdc7305f7d974b8dbc037f6c6ec8b5af343763660c841759f40e2249be
+DIST wcwidth-0.2.13.tar.gz 101301 BLAKE2B 33637e5582cff1bbc0f11c044d390dc18b635af923c7c89c79c07f20bafb44434ad79801b19d89c9e15b8bee79b52f5652ea3987e5578520aedfbb03f20fd6cb SHA512 1eadda149936cf2eefe5d09c411774dc87c8a358f2dd92d74f427d7b47f07c05557e849c46122d44788c2bd7c97eb85fc5f902d9a158d68ab9e352c5185ba2d5
EBUILD wcwidth-0.2.12.ebuild 712 BLAKE2B 48bf0341295e3aa28669cc6f992a5c5e886f953d5a415e055e3186603e9b65398668f5b61902cb2fd3120ff7f69dc82a0bec84cc368e2b96b530c40d0d67a71d SHA512 d3557a607996f84acb508ed3a4390de0a775aabc4c3c5574edb8e51fe51dbb83d04567bdc678479301944600ec0eddbb4e13634ee10d59d3e2be17581f26eca4
+EBUILD wcwidth-0.2.13.ebuild 720 BLAKE2B e487cdc2e501ef056624e8e4ce49fc3f91637c185fc5cfeb204ea4e712c062639c094272a473d1e2c54afc255a34e9c6cdccdaccb2ac54ec9ef995d966632018 SHA512 e540406f63dfba5abc8a97738906739a3f7e4d3d8435044845f0b29d3b06fdf53fa1f2e66216d4b0690403beb69186c3aecb37ecfdc084f28c575d5bf236ca28
MISC metadata.xml 402 BLAKE2B 86714d496f80fe46cb313bed026135b2712ddfb47fea5994d0021516aa6ad28eb5fc52d37b37a7a224ec0613681b27ee039f4ac734430d94aafe4ec8946cecc7 SHA512 85c0e684f66a5582ca63d6f72c4e69101e8ec30f8e03c52e972fa36a2e6b6d2a8f019fb33a1e39e73fb37de25c82b906b18ac626afdd0a93d97db2ddcf485063
diff --git a/dev-python/wcwidth/wcwidth-0.2.13.ebuild b/dev-python/wcwidth/wcwidth-0.2.13.ebuild
new file mode 100644
index 000000000000..236793d8ec68
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.2.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="
+ https://pypi.org/project/wcwidth/
+ https://github.com/jquast/wcwidth/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}
+
+python_install_all() {
+ docinto docs
+ dodoc docs/intro.rst
+ distutils-r1_python_install_all
+}