summaryrefslogtreecommitdiff
path: root/dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild')
-rw-r--r--dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild b/dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..82fdf2f8eb5e
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.2.5-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="https://pypi.org/project/wcwidth/ https://github.com/jquast/wcwidth"
+SRC_URI="
+ https://github.com/jquast/wcwidth/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
+ ' -2)"
+
+distutils_enable_tests pytest
+
+DOCS=()
+
+src_prepare() {
+ sed -e 's:--cov-append::' \
+ -e 's:--cov-report=html::' \
+ -e 's:--cov=wcwidth::' \
+ -i tox.ini || die
+ sed -i -e 's:test_package_version:_&:' tests/test_core.py || die
+ distutils-r1_src_prepare
+}